Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I just upgraded to 11.10, but during the installation something happened towards the end with the adobe flash package and the installation just ended. It said it would try to recover, but didn't, and now I'm booting fine into 11.10. However, when I try to open Ubuntu Software Center, I get this dialog box:

enter image description here

When I click repair, it asks for the root password, then pops this up again. It will continue to pop up until I close the software center. I've tried to update/upgrade my repository, I've tried to sudo apt-get install -f, I've tried removing the adobe flash plugin, but nothing seems to be helping.

[EDIT] requested output (sudo apt-get update && sudo apt-get upgrade):

Ign stable InRelease
Ign stable InRelease                                                                                                                                                                          
Get:1 stable Release.gpg [198 B]                                                                                                                                                              
Get:2 stable Release.gpg [198 B]                                                                                                                                                              
Ign oneiric InRelease                                                                                                                                
Ign oneiric InRelease                                                                                                   
Ign oneiric-security InRelease                                                                                        
Ign oneiric InRelease                                                                                               
Get:3 stable Release [1,347 B]                                                                                              
Ign oneiric InRelease                                                                                                                                    
Get:4 stable Release [1,347 B]                                                                                                                                             
Hit oneiric Release.gpg                                                                                                                                  
Hit oneiric-security Release.gpg                                                                                                               
Hit oneiric Release.gpg                                                                                                                   
Hit oneiric Release.gpg                                                                                                 
Get:5 stable/main amd64 Packages [1,207 B]                                                                                  
Hit oneiric Release.gpg                                                                                                                                              
Get:6 stable/main i386 Packages [1,199 B]                                                                                                         
Hit oneiric-security Release                                                                                      
Hit oneiric Release                                                                                                               
Hit oneiric Release                                                                                            
Ign stable/main TranslationIndex                                                                                   
Get:7 stable/main amd64 Packages [764 B]                                                    
Hit oneiric Release                                                                                                                  
Get:8 stable/main i386 Packages [779 B]                                                                                                  
Hit oneiric-security/main Sources                                                                                                  
Ign stable/main TranslationIndex                                                                                  
Hit oneiric/partner amd64 Packages                                                  
Hit oneiric/main Sources                                                                
Hit oneiric Release                                                                     
Hit oneiric-security/restricted Sources                                                                      
Hit oneiric-security/universe Sources                                                                       
Hit oneiric-security/multiverse Sources                                               
Hit oneiric-security/main amd64 Packages                                                                    
Hit oneiric-security/restricted amd64 Packages                                                              
Hit oneiric/partner i386 Packages                                                                         
Ign oneiric/partner TranslationIndex                                                
Hit oneiric/main amd64 Packages                                                         
Hit oneiric/main i386 Packages                                                          
Hit oneiric/main Sources                                                                                      
Hit oneiric/main amd64 Packages                                                                               
Hit oneiric/main i386 Packages                                                          
Ign oneiric/main TranslationIndex                                                       
Hit oneiric-security/universe amd64 Packages                                          
Hit oneiric-security/multiverse amd64 Packages                                        
Hit oneiric-security/main i386 Packages                                               
Hit oneiric-security/restricted i386 Packages                                         
Hit oneiric-security/universe i386 Packages                                           
Hit oneiric-security/multiverse i386 Packages                                         
Ign oneiric-security/main TranslationIndex                                            
Ign oneiric InRelease                                                               
Ign oneiric-updates InRelease                                                       
Ign oneiric/main TranslationIndex                                                       
Hit oneiric/main Sources                                          
Hit oneiric/main amd64 Packages                                   
Hit oneiric/main i386 Packages                                    
Ign oneiric/main TranslationIndex                                 
Ign oneiric-security/multiverse TranslationIndex                
Ign oneiric-security/restricted TranslationIndex                
Ign oneiric-security/universe TranslationIndex                  
Hit oneiric Release.gpg                                       
Ign stable/main Translation-en_US                                                           
Hit oneiric-updates Release.gpg                                                     
Ign stable/main Translation-en                                                              
Ign oneiric/partner Translation-en_US                                               
Ign stable/main Translation-en_US                                                           
Ign stable/main Translation-en                                                              
Ign oneiric/partner Translation-en                                                  
Ign oneiric-security/main Translation-en_US                                           
Ign oneiric-security/main Translation-en                        
Ign oneiric/main Translation-en_US                                
Ign oneiric-security/multiverse Translation-en_US               
Ign oneiric-security/multiverse Translation-en
Ign oneiric-security/restricted Translation-en_US
Ign oneiric-security/restricted Translation-en
Ign oneiric-security/universe Translation-en_US
Ign oneiric/main Translation-en_US                                
Ign oneiric/main Translation-en                                   
Hit oneiric Release                                           
Ign oneiric-security/universe Translation-en                     
Ign oneiric/main Translation-en             
Ign oneiric/main Translation-en_US
Ign oneiric/main Translation-en
Hit oneiric-updates Release
Hit oneiric/main Sources
Hit oneiric/restricted Sources
Hit oneiric/universe Sources
Hit oneiric/multiverse Sources
Hit oneiric/main amd64 Packages
Hit oneiric/restricted amd64 Packages
Hit oneiric/universe amd64 Packages
Hit oneiric/multiverse amd64 Packages
Hit oneiric/main i386 Packages
Hit oneiric/restricted i386 Packages
Hit oneiric/universe i386 Packages
Hit oneiric/multiverse i386 Packages
Hit oneiric/main TranslationIndex
Hit oneiric/multiverse TranslationIndex
Hit oneiric/restricted TranslationIndex
Hit oneiric/universe TranslationIndex
Hit oneiric-updates/main Sources
Hit oneiric-updates/restricted Sources
Hit oneiric-updates/universe Sources
Hit oneiric-updates/multiverse Sources
Hit oneiric-updates/main amd64 Packages
Hit oneiric-updates/restricted amd64 Packages
Hit oneiric-updates/universe amd64 Packages
Hit oneiric-updates/multiverse amd64 Packages
Hit oneiric-updates/main i386 Packages
Hit oneiric-updates/restricted i386 Packages
Hit oneiric-updates/universe i386 Packages
Hit oneiric-updates/multiverse i386 Packages
Hit oneiric-updates/main TranslationIndex
Hit oneiric-updates/multiverse TranslationIndex
Hit oneiric-updates/restricted TranslationIndex
Hit oneiric-updates/universe TranslationIndex
Hit oneiric/main Translation-en
Hit oneiric/multiverse Translation-en
Hit oneiric/restricted Translation-en
Hit oneiric/universe Translation-en
Hit oneiric-updates/main Translation-en
Hit oneiric-updates/multiverse Translation-en
Hit oneiric-updates/restricted Translation-en
Hit oneiric-updates/universe Translation-en
Fetched 7,039 B in 5s (1,347 B/s)
Reading package lists... Done
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages have been kept back:
0 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.
share|improve this question
This is still a problem, in case anyone has any more ideas. Thanks! – Dave Oct 15 '11 at 5:10
As an update on this, I am having trouble with Flash, which was the original culprit during the upgrade. I can't seem to get it installed, and it won't work in either Chrome or Firefox. – Dave Oct 16 '11 at 12:51
Use synaptic to check for broken packages / try sudo dpkg --configure -a / why is WINE held back? – matt Jan 17 '12 at 11:16
@matt wine is probably held back because, to upgrade it, packages would have to be installed (or removed). sudo apt-get upgrade will not install or remove packages. To upgrade packages even when doing so requires installation or removal of packages, you must use sudo apt-get dist-upgrade. It would perhaps be useful to have the output of sudo apt-get dist-upgrade added to the question as well. (sudo apt-get update should be run first, but its output doesn't have to be added again unless it's different from before.) – Eliah Kagan Jun 1 '12 at 20:06
You can try sudo apt-get -f upgrade. I did it and it worked. – user155954 May 6 '13 at 1:03

It seems your actual package catalog is fine, so I'm assuming the Software Center app-install cache is corrupted. Try deleting it with the following command:

rm -r ~/.cache/software-center
share|improve this answer
Unfortunately, that does not seem to have had any effect on the problem. Is there something I should do after deleting the cache? – Dave Oct 14 '11 at 16:14
No... it should be regenerate on its own on relaunching the Software Center. Looks like my solution wasn't the right one. – Jjed Oct 14 '11 at 16:19
I Had a prob that when trying to launch Ubuntu Software Center in Ubuntu 12.04 LTS, the app would open and not populate, and stop responding, regardless of how long I left it. the command rm -r ~/.cache/software-center fixed the issue as recommended as per above, thank you very much, not sure if this is the right place to put this, but hope it helps some one else out. Antonio – Mochan Jan 4 '13 at 11:37

check out solution mentioned in: How to fix broken repository information?

 sudo apt-get check && sudo apt-get update 
 sudo apt-get upgrade

It seems to work good for me

share|improve this answer

I posted the answer however I was told the is incorrect, I did experience the same thing right now it cause by the adobe flash play. I forcefully close it.And that cause the worms to bleed. Open terminal and type the following command sudo dpkg --configure -a it gonna work. Thanks

share|improve this answer

Try this procedure. It usually works for this sort of problem, even when the solutions people have proposed here so far don't. Furthermore, if it doesn't work, it still does give useful diagnostic information. So if it doesn't work, then please provide all the text from the Terminal. It will be rather long, so instead of putting it into your question, you may want to paste it at You'll get a URL to see it, which you can add to your question.

share|improve this answer

I recommend removing all flash from your computer by opening nautilus as root and searching "adobe flash" and delete all the results. Then do apt-get update

share|improve this answer
You should not use Nautilus to manually delete all files from any blanket search result unless you really know what you are doing. Per-user flash-related files that can be safely deleted are located in .adobe and .macromedia (in the user's home directory). Everything else should be removed with package management (e.g., sudo apt-get purge ...) where ... is replaced with the names of installed Flash packages. You can't remove systemwide configuration and program files with Nautilus running as a non-root user anyway, and it's very dangerous to do so running Nautilus as root. – Eliah Kagan Jun 1 '12 at 20:21
I had the same issue and did (opening nautilus as root and searching "adobe flash" and delete all the results. Then do apt-get update) and it fixed my problem. I will agree is was probably a bad idea, but it fixed my problem. – Matt Timbrook Jun 4 '12 at 1:00

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.