Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've just installed new Ubuntu 11.10. The installation was successful. But when I start the Ubuntu, the splash screen does not work, and I get error (always some of these) "mountall: Plymouth command failed", "mountall: Connect to Plymouth was lost" or "Checking battery state..."

I'm sorry, if the error messages are incorrect because I translated two first of them from Finnish (my system is in Finnish) to English, so they maybe couldn't be just right.

I have already asked from our Finnish community, but they couldn't answer. Could anybody here?

share|improve this question

closed as too localized by Bruno Pereira May 23 '12 at 17:45

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

If this is a new install - please add to your grub boot options "nomodeset xforcevesa acpi=off" - if this works - try combinations of these 3 options to find which allows you to boot correctly. – fossfreedom Oct 14 '11 at 13:31
Where can I do that? – Aleksi Kinnunen Oct 14 '11 at 13:43
try the following AU Question and answer:… – fossfreedom Oct 14 '11 at 13:50
set it for "nomodeset quiet splash", but it still says "Checking battery state...". Secondly it went longer than before. What could I do? – Aleksi Kinnunen Oct 14 '11 at 15:23
have you tried "acpi=off" and "xforcevesa" and "xforcevesa acpi=off" etc etc?? - dont forget - Since this is an Question and Answer site, add what you have tried as an edit of your question. – fossfreedom Oct 14 '11 at 15:37

I had this problem sometimes when I have updated from beta 11.10, I dont know what the exact problem is but it shows starting lightdm fail then it stops at checking bettery state, so u need to start lightdm press ctrl + alt + F2 login and type sudo lightdm it should work. and for me I have installed gdm removed lightdm

share|improve this answer

After a clean install:

  1. Let the system start booting until it stops near the "battery state" message
  2. alt+f1 to open the terminal. Log in with your credentials.
  3. sudo apt-get remove nvidia-173
  4. sudo apt-get install nvidia-current
  5. if you've run "startx" earlier: rm -f ~/.Xauthority
  6. sudo reboot
  7. Happy Ubuntu'ing!

The issue seems to be with the Nvidia drivers. When you run startx, the X server looks for nvidia-173 (or 171, can't quite remember), but they seem to be faulty. Uninstalling the old driver and installing a newer one fixed the issue for me.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.