Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I use graphics software like GIMP, Inkscape & Blender extensively for my business. But most of them require the use of the Alt key in some way or the other. Come Ubuntu 11.10, I haven't been able to find any way to change the shortcut for window moving/resizing from Alt+LMB/MMB to Super/Meta+LLM/MMB. This option was present in the 'Windows' settings in Gnome2, but it is not present anywhere in Gnome3. And yes, I have tried searching through the Shortcuts tab in Keyboard settings, its not there.

Any help regarding this would be useful. Thanks.

share|improve this question
add comment

4 Answers 4

up vote 5 down vote accepted
  1. Install compizconfig-settings-managerInstall compizconfig-settings-manager.

  2. Open CompizConfig Settings Manager and navigate to the Resize Window plugin.

  3. Click the <Super>Button2 button and rebind the shortcut.

    enter image description here

share|improve this answer
1  
It didn't work instantaneously after changing the settings for the Move pulgin and the Resize plugin, it took a logout->login to work. But yea, this was it! Thanks! –  Ravish Malik Oct 15 '11 at 11:08
    
Thanks, this was just what I needed too. The comments about logging out and logging back in to get it to work also was important. –  Dave May 1 '12 at 14:54
add comment

Well, at leaste for Blender, you don't really need to go all this trouble. Go File > User Preferences and select the Input tab. On the search field type "edge" (without the quotes) Voila. To cut this short story shorter the shortcuts on blender are 'Ctr + Alt + Select Mouse' and 'Shift + Ctr + Alt + Select Mouse' respectively..

share|improve this answer
add comment

Install compiz-manager from Software Center. When yoy have installed (and opened) it, search there "Unity plug-in" or some similar and click it. Select Switcher and there you can select hte buttons which will open the Switcher.

share|improve this answer
add comment

In Ubuntu 13.10 this worked for me:

  1. Open a terminal (Ctrl+Alt+T) and type sudo apt-get install dconf-editor. Enter your password when prompted and after the installation is finished type dconf-editor to open the Configuration Editor.
  2. Now either hit Ctrl+F and use the hereby summoned field to search for mouse-button-modifier or navigate to org.gnome.desktop.wm.preferences and find the same.
  3. Change it's value from <Alt> to something else (<Super> will probably work best) and enjoy your improved workflow!

NB: Leaving the field empty will get you stuck in drag-mode, unable to click the "Set to Default" button. You can bring the focus to this button by pressing Tab until a fine orange rim shows up around it. Then press Space and repeat step 3.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.