Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I just did a fresh ubuntu 11.10 install on my laptop, but i cannot manage to start the graphic mode.

When the laptop boots it gets stuck after the loading screen.

I tried to Ctrl-Alt-F1, log in and start manually the X server, but i get this error:

FATAL: Module nvidia_173 not found.    
(EE) NVIDIA(0): Failed to load the NIVIDIA kernel module!

The module is installed of course, and i tried also to reinstall nvidia-current.

I already tried following same thread on this issue, but nothing seems to work for me.

Anyone knows a valid solution?


share|improve this question

Try reinstalling the nvidia-173 module:

sudo apt-get install --reinstall nvidia-173

and reboot

That worked for me!!

share|improve this answer
awesome, this worked for a friend's computer who had the same problem! – Munim Oct 18 '11 at 12:39

Make sure the MBR is pointing to the upgraded kernel, initrd, etc. I use EasyBCD to triple boot, so when the upgrade to 11.10 cam last night and X wouldn't start this morning, it took a while before I realized I had to update the NeoGRUB file to point it from 2.6.35-22 to 3.0.0-12. After doing that, everything is perfect.

share|improve this answer

I had the same issue and reinstalling nvidia-173 worked for me also.

More details for new users:

When booting, the symptoms are: you see a list of events with [OK] or [fail], and then nothing further happens. I had several [fail], apparently unrelated. Linux has tried to start X windows (the graphics display) and failed, quietly. Now if you enter Ctrl-Alt-F1, Linux starts a terminal (a non-graphical command line.) Linux is running, just without graphics. You can examine the file /var/log/Xorg.0.log to find the error: (EE) NVIDIA(0): Failed to load the NIVIDIA kernel module!

Then, enter as described earlier:

$ sudo apt-get install --reinstall nvidia-173

Note it is not just install, but a --reinstall. Linux downloads it from the net, compiles it and installs it. Then reboot.

Then Ubuntu should start. I got an alert that new proprietary drivers were available. I started System Settings>Harware>Additional Drivers. It showed that a "version current" was the recommended version but that "version 173" was installed. I don't think it matters (both seem to fully use the graphics card) but I chose "version current" and the "Activate" button. Then restarted. That version (whatever it is?) also seems to work.

Possibly you can forestall the alert that new drivers are available by installing "nvidia-current" the first time?

share|improve this answer

I did this and got to the login page, but I cannot log in. I see an NVIDIA logo and then get back to the lightdm.

I have tried with nvidia-173 and nvidia-current, and using nvidia-xconfig, but nothing. I believe my laptop has a GeForce 8400 and it's a Dell XPS M1530.

is this reported anywhere?

share|improve this answer

You should find there is another package called something like nvidia-current-upgrades visible to "restricted drivers" GUI or the jockey command line interface. Try installing/activating this. Worked for me.

share|improve this answer

I have a pretty good solution for you. press Ctrl+Alt+F1. After that login with your username and password. After that type wget Wait for the download to complete, after that type chmod 777 After that type service lightdm stop and then sh Follow the instructions, restart if needed, and after restarting your PC you will have latest NVIDIA driver and a good-working graphic card.

share|improve this answer

Since reinstalling nvidia-173 didn't work for me, I'm going to tell you how I solved this issue. I added a repository with the last version of the NVidia drivers. Here it says you have to add the swat-x ppa:

sudo apt-add-repository ppa:ubuntu-x-swat/x-updates sudo apt-get update sudo apt-get install nvidia-current

This worked for me today when I was installing Kubuntu 11.10 in a Macbook Pro.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.