Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

After creating a xorg.conf I've got able (there was a nasty bug in confless mode: always overlaying the second display over the first instead of using the second physical screen) to set up a second display (a DSUB-attached classic 17-inch panel) with ARandR (under XUbuntu 11.10) on Intel GMA X4500MHD (a Dell E5500 laptop). But the maximum resolution appearing in it's menu (for this particular display) is 1024x768 while its native resolution is 1280x1024. How to fix this?

I use to switch between different external monitors (with different characteristics) and working without any some times, so I'd like to avoid any hardcoding. But, if it is hardly possible to make the thing detect supported resolutions correctly, I'd be glad to know how to add them manually (the way meant to work if the monitor is physically capable of a resolution specified, though not advertising it correctly).

share|improve this question
    
Does grandr also not show the native resolution? I know it's a front-end to xrandr like arandr, but it might be worth a try. Have you specified the maximum size of both displays in xorg.conf? Although you want to avoid hard-coding, so this might not be an option. What happens if you remove (backup) xorg.conf and try grandr? –  SabreWolfy Oct 25 '11 at 22:37
    
@sabrewolfy, there are no resolution settings in my xorg.conf. I will try removing xorg.conf again and trying grandr as you suggest. –  Ivan Oct 26 '11 at 0:35
    
I've had success with grandr on every occasion I've used it. It configured a 22" DVI (1680x1050) and a 23" DVI (1920x1080) on an nVidia card from live X/Ubuntu and CrunchBang boots. –  SabreWolfy Oct 26 '11 at 6:57
    
grandr still says the highest resolution available for the external ("VGA1") screen is 1024x768. Deleting xorg.conf doesn't change anything. –  Ivan Nov 1 '11 at 0:31
    
Is the total resolution you are trying for (with both screens) exceeding the maximum resolution your internal graphics card is capable of? –  SabreWolfy Nov 1 '11 at 8:42
show 4 more comments

1 Answer 1

Try to use disper to extend your desktop to an external screen.

disper -e extends to an external screen, disper -s deactivates it. Now when extending to your external monitor you can use extra options like:

--resolution= [1600x900,1280x1024] 
--direction=  [left,right,top or bottom]
--displays=   [auto or list of displays] 

and give the two resolutions for the two screens, the relative position and the type of view - please refer for details to man disper. I am using different external screens and already with the plain disper -e, disper -s commands everything is set and (native) resolutions are automatically detected.

share|improve this answer
    
disper still says the highest resolution available for the screen is 1024x768. disper -l gives "display LVDS1: LVDS1 resolutions: 640x480, 800x600, 1024x768, 1152x864, 1360x768, 1440x900 display VGA1: VGA1 resolutions: 848x480, 800x600, 1024x768, 640x480", where LVDS1 is the laptop's built-in panel and VGA1 is the screen meant to be 1280x1024. –  Ivan Nov 1 '11 at 0:30
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.