Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I installed Ubuntu 11.10 and the installation runs through fine. It then says reboot, and the machine says 'inserts a boot disk' which means the hard disk isn't bootable. The primary hard disk is an EFI device, and nothing seems to work.

The machine in question is an Acer Aspire M3970 desktop. Core i5 2300, with 8Gb Ram. Main boot drive is an SSD (Vertex 2E 60Gb). I am trying to install the 11.10 x64 version. The installation I have tried from CD and USB stick. It goes through the install, allows you to partition the drives then installs all the packages. At the end it goes for a reboot, and asks you to remove the installation media.

The PC then restarts and says no bootable disk. I tried it many times. In the end I have installed Fedora 15 x64 which works straight away with no messing. Unless this issues is fixed I have to drop 11.10 as a viable option.

From my experience F15 isn't quite as polished as Ubuntu, but in this case - it works!!

Is this a widespread problem or am I unique?

share|improve this question
I am having exactly the same problem, on different hardware. Can I please ask if you were able to resolve this with 11.10, and how? thanks – Eoin Feb 26 '12 at 12:46

The problem is the EFI does not recognise the bootloader and even though GRUB is installed it is not able to run correctly due to not being able to be read from the MBR.

I found a solution on Ubuntu Forums that hopefully will solve your issue and get your installation working.

SOLUTION 1) GPT partitioning seemed to be a problem for the Ubuntu installer. I took the SSD disk out of the PC, plugged it to another PC with a SATA-to-USB adapter and created a normal partition table on it without any of the non-working GPT crap. I created the partitions as follows (with cfdisk, gparted also works):

1: FAT32 partition for the EFI bootloader. I set this to 500 MB size and formatted it with mkfs.vfat. 2: / (root) partition (ext4). 3: /home partition (ext4).

I use no swap on computers like this that have 16 - 32 GB of RAM.

2) I kept the SSD disk plugged to the other PC with the SATA-to-USB adapter and mounted the FAT16 EFI partition. I created a folder efi/grub under it with the command "mkdir -p efi/grub".

3) Now the disk was ready for installation. I put the SSD disk back to the new PC, booted up Ubuntu installation from the USB disk and installed it as usual, formatting / and /home as ext4 in the process.

SUCCESS!!! The PC boots in about 10-15 seconds like you'd expect from an SSD disk. The network card on this motherboard works on Ubuntu 11.10 out-of-the-box as well. 10.04 doesn't seem to recognise it, 11.04 I'm not sure.

My advice to others reading Ubuntu's EFI/UEFI instructions: Do NOT start recompiling GRUB or other more complicated stuff. It is completely unnecessary.

The instructions are outdated for 11.10 and just creating the FAT partition with a folder efi/grub is enough for Ubuntu to automatically recognise and install the bootloader there. Ubuntu 11.10 already has a working GRUB for EFI systems, you do NOT need to compile one yourself, at least not for the Asus EZ.

So, in short: create the partitions on a non-EFI system, mkdir 2 folders and install. If I only knew from the start that it was this simple.


Although this references removing the drive from the PC other threads have not removed the drive, used the same method and had success - good luck and let us know how it goes.

share|improve this answer

I have had a similar problem on my hardware with assorted versions of Ubuntu. It is not that the disk unbootable it was that the boot loader did not recognize the disk to boot from.

So when that machine is booting (right at the very earliest stages after power on) I get the prompt to "Press F8 to select boot media". I press F8.

That displays a menu of available devices, I select the device on which I installed the OS and then continue. It boots fine and works great.

BTW, I convinced myself this is yet another layer of security (layers are good regardless of how thin) as someone else trying to boot my machine will not succeed unless they know this trick! ;-)

share|improve this answer

protected by Community Feb 26 '12 at 12:59

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.