Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

As I understand it, in Ubuntu 11.04 setting the AutoHide setting on Compiz Config - Unity (see here) not only hid the launcher but prevented the launcher from influencing window placement.

However, since updating to Ubuntu 11.10 when I open a new window it gets indented the space of the launcher. I just want new windows to open flush left. This is annoying, because I like to have two windows on my large screen, one taking up the left half of the screen and the other taking up the right half of the screen. Indenting causes them to overlap.

How can I stop Ubuntu 11.10 thinking that the launcher takes up desktop space when placing windows?

The following screen shot shows what I'm talking about. I've just opened chromium and the window is indented by the width of the launcher.

enter image description here

share|improve this question
    
An luck on this? –  TheDeeno Jan 15 '12 at 18:18
    
@TheDeeno no. I've just adapted to it, but I'd still like a solution. –  Jeromy Anglim Jan 15 '12 at 21:26
add comment

3 Answers 3

Just move the window to the left, and the launcher will go away. It is only auto-hidden when something else wants that space.

share|improve this answer
4  
thanks, but I know that I can move the window, I want the window to open by default flush left if when the window was last opened, it was flush left. For example, if the last time the window was closed, it was flush left with the screen, it should open next time flush left with the screen rather than being indented by the width of the launcher. In essence, I want default placement of windows to be consistent with what I consider intelligent behaviour. –  Jeromy Anglim Oct 19 '11 at 2:20
add comment

I wonder if this worth a shot:

Go to CCSM - (Window Management)Place Windows - Enable "Workaround" & Placement Mode "smart"

share|improve this answer
    
thanks for the suggestion; I already have "smart" mode activated; I tried adding workarounds, but it did not change the behaviour of window placement. –  Jeromy Anglim Oct 24 '11 at 22:26
add comment

If you want all your windows to be initially placed in the top left corner, the follow settings in ccsm > Place Windows makes it work for me: in the fixed window placement tab, add an entry for Windows with fixed positions and set the type to any, x to -1, y to 48 and untick keep in workarea. It's quite a hack and the window is 1px off screen (which you'll hardly notice).

I usually use the ccsm Grid plugin to place my windows, since I normally want them side-by-side anyway i.e. Alt-Kp-4 for left tile, Alt-Kp-6 for right tile etc. Grid ignores the launcher if set to auto-hide.

share|improve this answer
    
Thanks for the suggestion. –  Jeromy Anglim Jan 21 '12 at 0:40
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.