Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Yesterday I upgraded my Ubuntu Natty to Oneiric on my notebook HP G61 (wifi card Atheros ar9285). When I start on normal mode wifi dont work: menu under tray-icon says; "Wifi hardware switched off".

If I put the command "rfkill list" I get this answer:

0: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: yes

then I launch "sudo rfkill unblock all" but the output of "rfkill list" dont change.

So when I start on recovery mode wifi work normally. This is the output of "rfkill list":

0: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: no
1: hp-wifi: Wireless LAN
    Soft blocked: no
    Hard blocked: no

Any suggestion?

share|improve this question
Do check my answers and I am pretty sure it will be helpful – raghavsood33 Dec 7 '13 at 21:30

The message hard blocked: yes, means that there is a hardware switch that is switching off the wireless adapter.

Do you have to use a Fn+key combination to switch on wireless? Are you dual booting with another operating system and have you switched off wireless in that operating system? The windows operating system has the ability to switch off the wireless hardware and Ubuntu/Linux does not have to ability to over-ride that action.

You may also need to see this link

getting atheros ar9285 to work


share|improve this answer
First thanks to answer to my question. yes I have got a dual boot with windows 7 inside the notebook. I have already try to boot in windows and the wireless work perfect with switch turned on at the start and when I stop the system. The net tray-icon of ubuntu told me that the wifi is turned off by a switcher but when I try to click the button it dont work. But the thing that look strange is the difference between the recovery mode (wifi work perfectly; rfkill list output two items) and the normal mode (wifi blocked; rfkill list output one item); I can't understand. – gianni Oct 14 '11 at 21:13
Ah this worked for me. Thanks so much – Sepero Jul 8 '12 at 12:46

Try (with your laptop off) removing the battery and the power cable and then press the power switch for about 30 seconds. When you're done, put all things (battery, power cable) back and then switch on your laptop again. Check if your wireless is back from the dead. It was the only thing that worked for me.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.