Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just upgraded to 11.10 (from 11.04). I was using the 'Classic Ubuntu' login as default before. When I now log in, I don't get the top bar (where you have Applications, Places, System normally). Instead I get like a menu with File, Edit, View, Go, Bookmarks and Help.

I also do not get the launcher thing on the left side (I am now using 'Ubuntu' to log in). Any idea what might be wrong? Any commands I can run to help debug this?

regards,

Wim

Edit: This is a screenshot of what I see. Screenshot

share|improve this question

closed as too localized by Marco Ceppi Oct 14 '11 at 17:38

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

2  
This maybe because the Ubuntu Classic in 11.04 was running Gnome 2.x but Ubuntu Classic in 11.10 runs Gnome 3. And Gnome went through some major changes while transitioning from version 2 to version 3. So probably nothing wrong with your installation :) –  nitstorm Oct 14 '11 at 8:52
    
What do you mean, nothing is wrong @nitstorm ? I don't have the normal menu at the top of my screen so I can't start any program, window decorations seem strange, ... –  Wim Deblauwe Oct 14 '11 at 11:51
    
A unity --reset might work here, but that's just a guess. –  Jorge Castro Oct 14 '11 at 14:43

3 Answers 3

up vote 1 down vote accepted

That is because the Compiz Unity plugin is accidentally deselected. Press Ctrl + Alt + T and type unity --replace and you would have your Unity back. Alternatively, if you have CompizConfig Settings Manager (CCSM) installed in your computer, you can type ccsm in Terminal and run the program. There, under the desktop heading, you can select 'Ubuntu Unity plugin' and your Unity would be back to normal.

Out of experience with this issue before. ;)

share|improve this answer
    
Had the problem again after a clean 11.10 install. I logged in using gnome classic desktop and than did unity --replace and it worked. Thx. –  Wim Deblauwe Oct 15 '11 at 10:11

For me it seems to be a problem with Compiz because the "Ubuntu Unity Plugin" isn't activated. I think it was the upgrade from your classic session into "Oneiric" so compiz didn't activated the Unity.

But when you prefer the classic session, open up one of your desktop-folders i can see on your screenshot. Here you can navigate to

/usr/share/applications

Here you can find Ubuntu Software Center and the Terminal (and perhaps still Synaptic Package Manager). So, when you have this, open one of your preferred programms. Way 01, the Ubuntu Software Center: Just search for "gnome-session-fallback". Way 02, the Synaptics Package Manager: The same way as in Software-Center,

Way 03, the Terminal:

sudo apt-get install gnome-session-fallback

When you had installed the gnome fallback session try to logout. You'll find a "gnome-classic" session and the same without any effects.

By the way, in the applications folder (mentioned above) you can find "Compiz Config Settings Manager" Here you can activate the Ubuntu Unity Plugin and your unity experience will start.

I hope, I was able to help you correctly

share|improve this answer
1  
Thanks for this. As it looked so dire, I re-installed Ubuntu and now it is ok again. So I am unable to verify if your answer is ok. –  Wim Deblauwe Oct 14 '11 at 14:46

There is nothing wrong. what you are experiencing is Ubuntu 11.10 Oneiric Ocelot.

We lost the top panel and the three menu choices when 11.04 was released but some people like you wanted to do things the old way and so you were given the choice to use Ubuntu Classic mode to make the transition to Ubuntu Unity easier. But that choice would only last until 11.10 was released. And now it has gone.

Move your mouse point to the top left of the screen and the Launcher will appear. Click the ubuntu icon at the top (also called the Big Funny Button) and the Dash will appear. In the search box type Help and click on the Help icon to load the Help documentation and learn how to use 11.10.

regards.

share|improve this answer
    
Can you look at the screenshot? The launcher never appears for me. –  Wim Deblauwe Oct 14 '11 at 12:50

Not the answer you're looking for? Browse other questions tagged or ask your own question.