Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just upgraded to Oneiric Ocelot and a problem that was already present in Natty has become worse - namely, the audio and video are not in sync both in VLC and in mplayer. The problem only used to happen in VLC in Natty.

Some searching on the Internet seems to indicate that pulse-audio might be the problem.

share|improve this question
    
I used to have this audio/video out of sync problem in 11.04 with VLC. I performed a clean install of 11.10 yesterday and to my delight the audio and video are perfectly synchronized in videos played with VLC. I would try completely reinstalling VLC to see if this problem was just "carried over". –  Trevor Oct 14 '11 at 16:14
add comment

3 Answers

up vote 4 down vote accepted

You are right about the problem that was Pulseaudio but that was solved in the 1.0 version of it which is the one that 11.10 is using. The other part of the problem is that you need the 1.1.12 version of VLC to make it work correctly with the new version of Pulseaudio. To do this add the following PPA (Which is the only one I have found so far with the 1.1.12):

sudo add-apt-repository ppa:n-muench/vlc

then do sudo apt-get update to get the new updates. After that just update VLC to the new 1.1.12.

Tested today and all problems related to sync are gone. Should be mention that this is a PPA from a 3rd party source. So if you would like to wait for Ubuntu to update VLC officially you can do that to. For myself I won't go through another version of Ubuntu with the sync problem again.

INFO - https://launchpad.net/~n-muench/+archive/vlc?field.series_filter=oneiric

UPDATE - There is no more the need to add this PPA since in the main repositories the VLC version 1.1.12 has been added. After todays update to the 1.1.12 version of VLC and using Ubuntu 11.10. Most if not all out of sync problems are gone.

Users need to update their Ubuntu to the latest daily updates which should provide the latest version of VLC (the 1.1.12 version). Already tested and all movies I have seen are working correctly.

share|improve this answer
add comment

I followed this instructions and worked great:

http://www.st4ck.com/it/post/ubuntu-11-04-vlc-out-of-sync/#Runtime

share|improve this answer
1  
Welcome to Ask Ubuntu! Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. Imagine the linked site goes down for maintenance or forever - your answer would become worthless. –  htorque Oct 18 '11 at 5:36
add comment

Have you tested changing the Caching Value under preferences ( ctrl + p, then Show settings: all ) enter image description here If you are using NAS as your media storage you should change in the SMB Access Module.

Test setting it to 0 if you are reading the file from your HDD.

share|improve this answer
    
How do you open this window to set the Caching Value? –  nitstorm Oct 14 '11 at 9:27
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.