Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a weak (having to reconnect frequently) "Intel Ultimate N WiFi Link 5300" built-in WiFi module in my Dell E5500 laptop and prefer to use a PCMCIA "Atheros AR5008" instead.

On Windows I just switch the laptop's wireless switch to off and the built-in module gets disabled (while Atheros (D-Link, actually) drivers just ignore it). But XUbuntu 11.10 understands the wireless switch and disables all the WiFi modules, including the PCMCIA one.

How to disable the built-in one without disabling the PCMCIA one in this case?

I don't want to have both of them (as I do now). Would be cool If I could switch them on and off easily and in an instant, as I can do in Windows.

share|improve this question
add comment

2 Answers 2

up vote 2 down vote accepted

You could try unloading the module (I believe that card uses iwlwifi iwlagn):

sudo rmmod iwlagn 

I've just checked, and it definitely works here with the BCM4312, wl module.

To bring it back up, use

sudo modprobe iwlagn

Since you wanted to permanently disable the built in wireless NIC, one way to do this is by blacklisting the supporting module. since Intel chipset is supported by the iwlagn driver, you can blacklist iwlang. Run:

gksu gedit /etc/modprobe.d/blacklist.conf

Add this line to the file:

blacklist iwlagn

Save the file and quit the text editor.

Now, even on reboot this module will not be loaded.

share|improve this answer
    
sudo ifconfig wlan0 down seems to cause just no effect on Network Manager (or whatever backs the standard XUbuntu network connection indicator applet). –  Ivan Oct 14 '11 at 8:58
    
The command is supposed to bring down the networking interface, not the Network Manager. What effect do you expect so see exactly? –  mikewhatever Oct 14 '11 at 9:25
    
The only visible effect is the wlan0 interface doesn't show in default ifconfig listing after the command. But the applet's menu still shows the found networks list twice - once per card. If I remove the PCMCIA card, one of the lists disapears and appears again as I plug the PCMCIA card back. I want the effect to be as if I had "unplugged" the built-in module the same way. Isn't there a way to disable a device? –  Ivan Oct 14 '11 at 9:43
    
You seem to be quite right. Unloading the wifi interface doesn't seem to make the networks disappear from the network manager applet. Try unloading the module instead, as described in the edited answer above. –  mikewhatever Oct 14 '11 at 15:30
    
sudo rmmod iwlwifi - ERROR: Module iwlwifi does not exist in /proc/modules :-( –  Ivan Oct 17 '11 at 15:40
show 2 more comments

Usually there is an option to disable builtin components in BIOS setup. So restart your laptop and open BIOS setup - usually by pressing F2 or F10 at startup - and try disabling the builtin NIC from there.

share|improve this answer
    
I still use the built-in module pretty frequently. I want to do it "on the fly", rebooting every time I need to enable/disable it is intolerable. Windows has no problems with this. Wasn't Linux meant to be smarter? :-) –  Ivan Oct 14 '11 at 8:38
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.