Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I installed ubuntu 11.10 and started with the software center. At first no software had the install option so I chose "Use the source". But the download (whatever it was downloading...) was taking too long so I canceled them.

When I next moved onto the "Get software" page, the INSTALL buttons had somehow appeared in any softwares I searched for, but none of them installed on my system when I tried to do so. I keep getting this "Failed to download package. Check connection" error even when I am parally working on Firefox.

share|improve this question

closed as not a real question by Bruno Pereira Mar 7 '12 at 23:02

It's difficult to tell what is being asked here. This question is ambiguous, vague, incomplete, overly broad, or rhetorical and cannot be reasonably answered in its current form. For help clarifying this question so that it can be reopened, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

Open a terminal and type sudo apt-get update && sudo apt-get upgrade Does that help? – Nitin Venkatesh Oct 14 '11 at 8:59
Hello, this question has no information and activity for a very long time. I am closing it for now. If by any reason you think this question is still viable or useful in anyways or that there is still a good chance it will be answered please flag it to a moderator or add a comment with the reasons why you want it open. Regards – Bruno Pereira Mar 7 '12 at 23:02

I got the same problem and tried both sudo apt-get update and sudo apt-get upgrade. But I was getting some error while updating. Then I changed my server (System Settings -> System -> Software Sources -> Download From) and it worked. You may try this.

share|improve this answer

Type sudo apt-get update in the terminal and wait until it finishes. This should fix the problem.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.