Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Okay, so I installed Ubuntu 11.10.

The thing is, when I click the home folder icon in the launcher (Win + 1), the home folder opens and a new icon appears in the launcher.

I want the windows to be highlighted in the first icon only if you catch my drift (4th icon).

I thought if I could remove the first icon and then right-click on the other icon and keep it in the launcher, it may work - but then folders open and the icon remains blank without any indication that a window is open (looks same as first icon).

Also, the icons numbered from top to bottom exclude the dash icon.

share|improve this question
add comment

7 Answers 7

up vote 2 down vote accepted

Disclaimer: I am not a Linux programmer, and this answer contains modifying files out of your home folder. It works for me, but do it on your own risk.

This problem appears when you configure your Home icon to have a quicklist for your favourite places the way it is described here.

The way to solve it, as written on the Bug 842257 page, is instead of creating a copy of /usr/share/applications/nautilus-home.desktop in ~/.local/share/applications and modifying this copy, rather modifying the original file. So the steps are:

  1. Delete the copy, if there is any: ~/.local/share/applications/nautilus-home.desktop

  2. Open a terminal and write:

    gksu gedit /usr/share/applications/nautilus-home.desktop
    
  3. Add this text at the bottom of the file, save and close.

    X-Ayatana-Desktop-Shortcuts=Videos;Documents;Music;Pictures;Downloads
    [Videos Shortcut Group]
    Name=Videos
    Exec=nautilus Videos
    TargetEnvironment=Unity
    
    [Documents Shortcut Group]
    Name=Documents
    Exec=nautilus Documents
    TargetEnvironment=Unity
    
    [Music Shortcut Group]
    Name=Music
    Exec=nautilus Music
    TargetEnvironment=Unity
    
    [Pictures Shortcut Group]
    Name=Pictures
    Exec=nautilus Pictures
    TargetEnvironment=Unity
    
    [Downloads Shortcut Group]
    Name=Downloads
    Exec=nautilus Downloads
    TargetEnvironment=Unity
    
  4. Reboot. It should work now, only one icon, with the quicklist.

If it still doesn't work, you can try Alt+F2, then run

unity --reset-icons

This will reset the icons of the original install on your launchbar, so you will have to repopulate it the way you want.

For getting the original nautilus-home.desktop file back, you can reinstall Nautilus and have the default settings and files:

sudo apt-get install --reinstall nautilus
share|improve this answer
add comment

The dash icon is not supposed to have a number since it would be redundant. The numbers are there so that you can activate an entry by pressing super+num. For instance, in your case, you would be able to launch and/or switch to Firefox by pressing super+2 and super+3 for the terminal. Launching the dash is done by a simple tap on super.

I have seen the bug you're referring to, but it was quite some time ago. Have you installed all upgrades? I've also seen that caused by an extension, but I don't remember which it was, but it may have been one to add quicklists. It should not be that way out of the box. Try opening a guest session and I'm sure that problem goes away. Would be nice if you confirmed that though.

share|improve this answer
    
jusy installed 11.10 yesterday and yes i upgraded it and my system is uptodate i did the numbering so it can be easy to interpret –  sarveshlad Oct 14 '11 at 15:45
add comment

I had the same issue. Make sure you don't have a custom nautilus-home.desktop file in ~/.local/share/applications. When I deleted that everything started working again.

I created one a while ago in 11.04, I guess something has changed in 11.10.

share|improve this answer
    
it removed my icon can u tell me how to get it back? –  sarveshlad Oct 20 '11 at 23:03
    
@SarveshLad Just click the dash icon (the Ubuntu logo) and type in nautilus. Drag the Home Folder icon into the launcher. Alternatively, you can open the application and then right click on the icon in the launcher and select Keep in launcher. –  Mike Walsh Oct 21 '11 at 16:46
    
i tried that and it did fix it but when i configured my icon to include my fav places.. it returned back to the existing situation –  sarveshlad Oct 21 '11 at 22:53
add comment

This is a confirmed bug. Bug 842257

It will be fixed at some point. There should only be one icon in the Launcher.

share|improve this answer
add comment

According to the bug, you just need to remove the following line from your custom Nautilus launcher (~/.local/share/applications/nautilus-home.desktop):

OnlyShowIn=GNOME;Unity;

I had this problem and removing that line and logging out and logging back in worked for me.

share|improve this answer
    
+1 It worked for me to. –  Beniamin Dec 7 '11 at 19:54
add comment

It is possible to have a custom nautilus-home.desktop file without this problem, as some other answers have mentioned. Another fix (mentioned here: Opening home folder causes another file cabinet icon to appear) is to go to gnome-tweak-tool and set Have file manager handle the desktop to off.

share|improve this answer
add comment

The problem is a contradiction in the 'Home Folder' file /usr/share/applications/nautilus-home.desktop

In the original file this line exists:

OnlyShowIn=GNOME;Unity;

while in quick list it is:

TargetEnvironment=Unity

This is solved by changing (TargetEnvironment=Unity) to:

TargetEnvironment=GNOME;Unity;

worked for me.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.