Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just did a clean install of 11.10. This is my first time using Unity. I installed Wine and successfully used it to install IrfanView. I can't figure out how to launch IrfanView from Unity. Do Wine programs not show up in Unity, and if not, how do I access them?

share|improve this question

4 Answers 4

Usually you can launch the program by typing the first few letters of the application's name into the Unity dash. In your case, you would begin typing "IrfanView" and if the application created any desktop shortcuts / start menu icons, then they should show up when you type the first few letters.

If that fails, you can try opening up Wine's "C drive" and find the application's executable. You can find most Wine applications in ~/.wine/drive_c/Program Files. Almost all Windows applications install to C:\Program Files, so you should see a folder for your application in there. Once you find the application, you can launch it by simply double-clicking it.

share|improve this answer
    
Huh, it doesn't show up at all on the dash. I am able to launch it from the Wine directory. I tried installing a couple of other apps, with the same result - they run, but don't show up in the dash. Since I haven't used Wine with Unity before I don't know if this is typical or an aberration. –  Morgan May Oct 14 '11 at 7:34
1  
I think wine apps will shown in dash after some time –  Extender Oct 14 '11 at 8:53
    
You were exactly right. I'm not sure why it took so long, but after a couple of reboots they showed up. –  Morgan May Oct 22 '11 at 11:30

I'm getting my first taste of Unity on 11.10 also. The way I add wine launchers to the Unity launch bar is to search for it by name in dash and drag the icon over to the bar. Wine integration is not great because clicking the launcher creates another icon named "Wine Windows Program Loader".

If your not seeing the apps in dash I would first fully update your system and reboot. If your still not seeing it make sure Zeitgeist is running. You should see processes called "zeitgeist-deamon" and "zeitgeist-datahub". They need to be present for dash to work properly. Either way try starting zeitgeist in debug mode and look for errors.

Don't use sudo

zeitgeist-deamon --quit
zeitgeist-deamon --log-level DEBUG

I tried viewing the debug info from Zeitgeist while installing a wine application but I saw nothing relevant coming out. The program showed up in dash instantly for me. Perhaps you may see errors or something useful.

share|improve this answer
    
Thanks for the advice. I think restarting a few times was all it took, in the end. I'm not sure if I updated during that time or not. –  Morgan May Oct 22 '11 at 11:32

I'm using the classic menu indicator for slowly weaning myself off the gnome panel and onto unity.

Whilst not a direct resolution for you it might be an easy workaround.

share|improve this answer

According to some posts, an application is shown in the Unity launcher if there is a "desktop" settings file for this application in the /usr/share/applications/ directory.

I remarked that a "desktop" file seems to be nothing else than a simple text file. If you right-clic on it, you can open a properties display window, but what you discover there is not very useful. Instead of it, if you copy this file into your home directory, rename it as .txt, you will see more and learn how you can do a launcher for your windows application.

I made a test launcher for a simple "mscalc.exe" which runs with "wine", and it works perfectly from the Unity launcher. Here is how i did:

(1) Put mscalc.exe and mscalc.ico intho a .wine subdirectory

(2) prepared a .txt file with this content:

[Desktop Entry]
Name=mscalc
Comment=Perform arithmetic, scientific or financial calculations
Keywords=calculation;calculator;mscalc
Exec=sh -c "cd /home/username/.wine/drive_c/windows; wine /home/username/.wine/drive_c/windows/mscalc.exe"
Icon=/home/username/.wine/drive_c/windows/mscalc.ico
Terminal=false
Type=Application
StartupNotify=true
Categories=Applications;Utilites;Calculator
X-Ubuntu-Gettext-Domain=windows-calculator

(3) Then I renamed my txt file to have a ".desktop" extension, changed the properties to make it executable. With the command line it was easy:

cp mscalc.txt mscalc.desktop
chmod +x mscalc.desktop

(4) And finally I placed it in the correct directory:

(edit: I remarked that some mistakes in the .txt file will cause the display of several warnings each time you log in. Though it does not seem to harm, better let the desktop icons on your desktop and not deploy them in the /usr/share/applications directory).

sudo cp -iv mscalc.desktop /usr/share/applications/

In this example I'm pretty sure there are many unnecessary or inacurate settings. But you will notice that

  • Inside this txt file I used "cd" to change the directory where the application will be running.
  • Of course you will have to change "username" into the real user
    name.
  • I used drive_c\windows directory to avoid the "program files" directory name, because the space is not easily accepted. But you can use it using an escape character (double "\"), like this: /home/username/.wine/dosdevices/c:/Program\\ Files/
  • The setting "Categories=Applications;" seems to be useful to see this application in the correct part of the launcher. I don't know the existing categories but Applications" seems correct to make it appear somewhere :-)
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.