Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just upgraded to Mythbuntu 11.10, and everything is working great, except for one snag.

Automatic login has gone away.

When I try to call up the interface for setting it, the option to make the setting is grayed out, as shown in the picture below.

I have tried running the mythbuntu-control-centre as a regular user, and as root, and either way, I can't access the settings.

How do I get my autologin function back?

greyed out autologin

share|improve this question
add comment

2 Answers

up vote 5 down vote accepted

I played with the lightdm.conf (the one located at /etc/lightdm/lightdm.conf not the one in /etc/init/) and got the auto login working for me:

[SeatDefaults]
user-session=mythbuntu
allow-guest=false
autologin-user=your username
greeter-session=mythbuntu-lightdm-gtk-greeter

Think that the greeter-session needed to be updated for mythbuntu.

share|improve this answer
add comment

I believe this is because Ubuntu switched from GDM to LightDM - the button in that dialog essentially configures GDM, which is now missing. I'm not sure what are the plans of Mythbuntu developes regarding this missing feature

Mythtv website has a wiki page about auto-login methods, some of them are not dependent on a particular login manager: http://www.mythtv.org/wiki/Frontend_Auto_Login

Here are some instructions on how to enable auto-login with LightDM in Ubuntu (which may or may not be slightly different than in Mythbuntu)

share|improve this answer
    
Thanks for the suggestions. Editing the lightDM config file did not change anything. The Wiki page may have helpful information, but that's a lot of information, so if the answer is there, I haven't found it yet. –  Dave M G Oct 14 '11 at 18:26
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.