Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I used to have Gnome-Do bound to Super+Space but this stopped working after upgrading to Oneiric. I assume this has something to do with the new Gnome/Compiz combination.

I've looked through both Gnome's and Compiz's shortcuts but can't see anything that would be nixing the keypress.

I've temporarily assigned it to Super+V and this works.

Any ideas or do I file this as a bug against Gnome-Do?

share|improve this question
add comment

1 Answer

up vote 4 down vote accepted

If you're using GNOME Shell, then mutter eats all Super keypresses - not just Super on its own, but any keybinding which uses Super. Or it did last time I checked. I need to figure out how to detect this and fall back to something like Ctrl+Alt+Space.

In Unity, however, Super+Space should work fine - it does for me ☺. Although Unity uses just Super to bring up the Dash, keybindings containing Super should still work.

share|improve this answer
    
However, you'd need to change/unset the Super key in Unity's plugin options. :-) –  htorque Oct 15 '11 at 8:08
    
What do you mean? <super> on its own brings up the dash, but <super>+<space> brings up Do; it works as you'd expect. At least, it does for me! –  RAOF Oct 15 '11 at 8:26
    
I tried a couple of shortcuts with the Super key and as soon as I press Super, the launcher unhides and the second key doesn't do anything. Or maybe I'm just too slow. :) –  htorque Oct 15 '11 at 8:58
    
I'm using Gnome Classic with Compiz so no Mutter and no Unity running. I've just set the shortcut back to Super+Space and it works. So very odd. I'll accept this because it's quite informative for other post-Gnome2 nomads like me. –  Oli Oct 15 '11 at 14:45
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.