Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

There was an option under Bluetooth preferences in 11.04 to easily hide the icon, but in 11.10, there's a little bar near the top right corner called Visibility. I'm assuming that's what hides or shows the Bluetooth icon, but I can't move it. Everything is locked in my Bluetooth preferences, and I see no unlock button.

Any ideas?

share|improve this question
add comment

4 Answers

up vote 7 down vote accepted

For 11.10

Alt+F2 and paste the following line:

gksu nautilus /etc/xdg/autostart

Search for bluetooth-applet.desktop and bluetooth-applet-unity.desktop files and delete them (I recommend you to backup them first).

Restart and that's all.

share|improve this answer
    
That works great, thanks José. –  Aibara Iduas Oct 20 '11 at 17:17
    
Works, thank you! I wish Ubuntu had kept the option from 11.04, don't know why they had to make this so complicated. –  Icedrake Oct 22 '11 at 16:19
add comment

I believe the correct way, as per the Desktop Application Autostart Specification, is to create user-specific configuration overriding the system default.

  1. cd ~/.config/autostart
  2. cp /etc/xdg/autostart/bluetooth-applet* .
  3. echo "Hidden=true" | tee -a bluetooth-applet*
share|improve this answer
    
Works for me, THX!! –  Martín Casco Jan 27 '12 at 23:48
    
This is definitely what people should be doing. –  Keith Smiley Jan 16 '13 at 17:22
add comment

Your bluetooth device needs to be plugged in or turned on for you to edit those settings.

If you want the icon gone altogether, either disable bluetooth in your BIOS (for built in bluetooth devices) or remove the adapter (if you use one).

share|improve this answer
    
So, you have to turn it on to get rid of it? Weird. –  Chris Morgan Oct 14 '11 at 3:46
1  
Cannot believe there is no software way to do it! People will still want to use their Bluetooth sometime... –  Waza_Be Oct 14 '11 at 10:28
    
@Profete162 it's either the indicator or no bluetooth, unfortunately. –  RolandiXor Oct 14 '11 at 13:40
    
I wonder why they can't keep it the same way it was in 11.04. In that, all you had to do was click a few buttons and the icon was hidden. Now I have to go through all this just to hide an icon (which I won't, Ubuntu is trying to waste my time). Seems like another way Ubuntu is going backwards. All I want to do is hide the icon, and yet I have to get a Bluetooth device to even think about changing any of the settings. –  Icedrake Oct 14 '11 at 20:05
2  
@Icedrake that's not Ubuntu's fault, that's GNOME's fault. Complain to the GNOME devs (you will be ignored, but at least you will have made your voice heard). –  RolandiXor Oct 14 '11 at 20:31
show 2 more comments

I have found out that you can run a certain command that will show all items in the 'Startup Applications' window. Then in there you can set the bluetooth from enabled to disabled. It also allows you to turn off other autostart applications that you might not want. Like Gwibber, I hate gwibber. Anyway the command to show the autostart applications is :

sudo sed -i 's/NoDisplay=true/NoDisplay=false/g' /etc/xdg/autostart/*.desktop

Copy/Paste and then open the 'Startup Applications' and make the changes. Be careful some of those are very useful.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.