Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I upgraded 11.04 to 11.10 using the online upgrade, and all went well except for Banshee. It shows under the sounds icon in the panel, and the icon for the program shows in Applications in the Dash, but clicking on either one does nothing (as does trying to run it from the terminal). There are no error messages or other indications that anything is wrong.

I tried uninstalling it and then reinstalling, but I receive the message "Package dependencies cannot be resolved". Hmmm ... how would I fix that?

UPDATE:

mdk@savina:~$ sudo apt-get update && sudo apt-get upgrade
[sudo] password for mdk: 
Ign http://extras.ubuntu.com oneiric InRelease
Ign http://archive.canonical.com oneiric InRelease                             
Ign http://security.ubuntu.com oneiric-security InRelease                      
Hit http://extras.ubuntu.com oneiric Release.gpg                               
Hit http://archive.canonical.com oneiric Release.gpg                           
Hit http://security.ubuntu.com oneiric-security Release.gpg          
Hit http://extras.ubuntu.com oneiric Release                         
Ign http://us.archive.ubuntu.com oneiric InRelease                             
Ign http://us.archive.ubuntu.com oneiric-updates InRelease                     
Hit http://archive.canonical.com oneiric Release                               
Hit http://security.ubuntu.com oneiric-security Release              
Hit http://extras.ubuntu.com oneiric/main Sources                              
Hit http://archive.canonical.com oneiric/partner Sources             
Hit http://security.ubuntu.com oneiric-security/main Sources         
Hit http://extras.ubuntu.com oneiric/main amd64 Packages             
Hit http://extras.ubuntu.com oneiric/main i386 Packages                        
Hit http://us.archive.ubuntu.com oneiric Release.gpg                           
Hit http://security.ubuntu.com oneiric-security/restricted Sources             
Hit http://security.ubuntu.com oneiric-security/universe Sources     
Hit http://archive.canonical.com oneiric/partner amd64 Packages      
Hit http://archive.canonical.com oneiric/partner i386 Packages       
Ign http://archive.canonical.com oneiric/partner TranslationIndex    
Ign http://extras.ubuntu.com oneiric/main TranslationIndex           
Hit http://security.ubuntu.com oneiric-security/multiverse Sources   
Hit http://security.ubuntu.com oneiric-security/main amd64 Packages            
Hit http://security.ubuntu.com oneiric-security/restricted amd64 Packages      
Hit http://security.ubuntu.com oneiric-security/universe amd64 Packages        
Hit http://security.ubuntu.com oneiric-security/multiverse amd64 Packages      
Hit http://security.ubuntu.com oneiric-security/main i386 Packages             
Hit http://security.ubuntu.com oneiric-security/restricted i386 Packages       
Hit http://security.ubuntu.com oneiric-security/universe i386 Packages         
Hit http://security.ubuntu.com oneiric-security/multiverse i386 Packages       
Ign http://security.ubuntu.com oneiric-security/main TranslationIndex          
Ign http://security.ubuntu.com oneiric-security/multiverse TranslationIndex    
Ign http://security.ubuntu.com oneiric-security/restricted TranslationIndex    
Ign http://security.ubuntu.com oneiric-security/universe TranslationIndex
Hit http://us.archive.ubuntu.com oneiric-updates Release.gpg         
Hit http://us.archive.ubuntu.com oneiric Release                     
Hit http://us.archive.ubuntu.com oneiric-updates Release                       
Ign http://extras.ubuntu.com oneiric/main Translation-en_US                    
Ign http://extras.ubuntu.com oneiric/main Translation-en                       
Ign http://archive.canonical.com oneiric/partner Translation-en_US   
Hit http://us.archive.ubuntu.com oneiric/main Sources                
Hit http://us.archive.ubuntu.com oneiric/restricted Sources          
Hit http://us.archive.ubuntu.com oneiric/universe Sources            
Hit http://us.archive.ubuntu.com oneiric/multiverse Sources          
Hit http://us.archive.ubuntu.com oneiric/main amd64 Packages         
Ign http://archive.canonical.com oneiric/partner Translation-en      
Ign http://security.ubuntu.com oneiric-security/main Translation-en_US
Ign http://security.ubuntu.com oneiric-security/main Translation-en
Hit http://us.archive.ubuntu.com oneiric/restricted amd64 Packages
Hit http://us.archive.ubuntu.com oneiric/universe amd64 Packages
Hit http://us.archive.ubuntu.com oneiric/multiverse amd64 Packages
Hit http://us.archive.ubuntu.com oneiric/main i386 Packages
Hit http://us.archive.ubuntu.com oneiric/restricted i386 Packages
Hit http://us.archive.ubuntu.com oneiric/universe i386 Packages
Ign http://security.ubuntu.com oneiric-security/multiverse Translation-en_US
Ign http://security.ubuntu.com oneiric-security/multiverse Translation-en
Ign http://security.ubuntu.com oneiric-security/restricted Translation-en_US
Ign http://security.ubuntu.com oneiric-security/restricted Translation-en
Ign http://security.ubuntu.com oneiric-security/universe Translation-en_US
Ign http://security.ubuntu.com oneiric-security/universe Translation-en
Hit http://us.archive.ubuntu.com oneiric/multiverse i386 Packages
Hit http://us.archive.ubuntu.com oneiric/main TranslationIndex
Hit http://us.archive.ubuntu.com oneiric/multiverse TranslationIndex
Hit http://us.archive.ubuntu.com oneiric/restricted TranslationIndex
Hit http://us.archive.ubuntu.com oneiric/universe TranslationIndex
Hit http://us.archive.ubuntu.com oneiric-updates/main Sources
Hit http://us.archive.ubuntu.com oneiric-updates/restricted Sources
Hit http://us.archive.ubuntu.com oneiric-updates/universe Sources
Hit http://us.archive.ubuntu.com oneiric-updates/multiverse Sources
Hit http://us.archive.ubuntu.com oneiric-updates/main amd64 Packages
Hit http://us.archive.ubuntu.com oneiric-updates/restricted amd64 Packages
Hit http://us.archive.ubuntu.com oneiric-updates/universe amd64 Packages
Hit http://us.archive.ubuntu.com oneiric-updates/multiverse amd64 Packages
Hit http://us.archive.ubuntu.com oneiric-updates/main i386 Packages
Hit http://us.archive.ubuntu.com oneiric-updates/restricted i386 Packages
Hit http://us.archive.ubuntu.com oneiric-updates/universe i386 Packages
Hit http://us.archive.ubuntu.com oneiric-updates/multiverse i386 Packages
Hit http://us.archive.ubuntu.com oneiric-updates/main TranslationIndex
Hit http://us.archive.ubuntu.com oneiric-updates/multiverse TranslationIndex
Hit http://us.archive.ubuntu.com oneiric-updates/restricted TranslationIndex
Hit http://us.archive.ubuntu.com oneiric-updates/universe TranslationIndex
Hit http://us.archive.ubuntu.com oneiric/main Translation-en
Hit http://us.archive.ubuntu.com oneiric/multiverse Translation-en
Hit http://us.archive.ubuntu.com oneiric/restricted Translation-en
Hit http://us.archive.ubuntu.com oneiric/universe Translation-en
Hit http://us.archive.ubuntu.com oneiric-updates/main Translation-en
Hit http://us.archive.ubuntu.com oneiric-updates/multiverse Translation-en
Hit http://us.archive.ubuntu.com oneiric-updates/restricted Translation-en
Hit http://us.archive.ubuntu.com oneiric-updates/universe Translation-en
Reading package lists... Done
Reading package lists... Done
Building dependency tree       
Reading state information... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
mdk@savina:~$ 
share|improve this question
    
what happens if you run sudo apt-get update && sudo apt-get upgrade in a terminal - any errors? Please copy and paste into your question the install command and the exact output you see in the terminal. –  fossfreedom Oct 13 '11 at 21:26
    
What if you run Banshee from terminal with debugging on? banshee --debug There should definitely be some clue there. –  michaelms Oct 13 '11 at 21:32
    
I can't run Banshee from a terminal; I uninstalled it so I could reinstall it, but it won't allow me to reinstall it because ""Package dependencies cannot be resolved". –  Kelley Oct 13 '11 at 22:11
    
Do you clear PPA list before update? –  Extender Oct 14 '11 at 8:38
    
No, I did not do that. –  Kelley Oct 14 '11 at 9:14

4 Answers 4

I had a similar upgrade issue with both Banshee and Liferea. The simple solution (for me) was to just destroy as much of the configuration as I could.

mv ~/.config/banshee-1{,-BACKUP}
mkdir ~/.config/banshee-1
cp ~/.config/banshee-1{-BACKUP,}/banshee.db

And then run Banshee. You should be good to go.

I've just tested this and it seems to work (your library is safe and if it still doesn't work, you can just restore from the -BACKUP version)

share|improve this answer

Remove ~/.cache/banshee-1 and run banshee.

share|improve this answer
up vote 0 down vote accepted

All the answers were good, and I did try what I could, but in the end I decided that I'd be better off with a fresh install. If there were unmet dependencies with Banshee, where else might there have been problems? So I backed up and then installed everything fresh, and now feel very good about everything. Yeah, it took more time, but now I'm pretty converted to doing fresh installs.

share|improve this answer
    
I'm picking my own as the answer, not because it's the best but because it's what I did, and because all of the answers were great and worth trying, so I can't decide on which one should be the answer. Thank you all so much for your help! –  Kelley Oct 16 '11 at 14:46

in terminal:

sudo apt-get build-dep banshee

if you get errors, check what unsupported software blocks your dependencies. in me case it was vlc. remove it completely. then you can reinstall banshee and vlc from oneiric sources.

share|improve this answer

protected by RolandiXor Oct 15 '11 at 18:54

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.