Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

How do I get the window snapping feature working again after reverting to Gnome Classic on 11.10 like suggested in this answer to How to revert to Gnome Classic

share|improve this question
up vote 4 down vote accepted

By default Gnome Classic does not run compiz which has the windows snapping feature.

By choosing Applications - Other - Startup Applications you can add the following startup application compiz --replace:

enter image description here

You can control windows snapping via CCSM -

sudo apt-get install compizconfig-settings-manager

enter image description here

share|improve this answer
If I run compiz --replace, it reverts back to the Unity UI. Is there a way to get it to just start compiz? – JesperE Oct 18 '11 at 8:44
very strange - the OP and myself have this working in Gnome-fallback... its worth a question! Remember to add details of your graphics. Also worth testing unticking the "unity plugin" option in ccsm to see if that helps. – fossfreedom Oct 18 '11 at 8:50
Unchecking the unity plugin in ccsm worked. Thanks! – JesperE Oct 20 '11 at 7:12

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.