Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I upgraded from 10.04 to 10.10, started my Evolution, deleted some messages, and now I can not empty the Trash folder... Even Ctrl+E could not help. I always get an error message: something went wrong in my home's hidden (?) mail directory.

Is this a 'normal feature' of the new default mail program of Ubuntu 10.10? I hope not!

share|improve this question

3 Answers 3

From you comment, the error message should read:

Error storing `~/.evolution/mail/local/myusername (mbox)': Summary and folder mismatch, even after a sync.

Probably the summary file is corrupted. To fix this you'd need to delete it and let Evolution rebuild it.

First make sure you backup your '~/.evolution' folder!

Now delete the summary file:

rm ~/.evolution/mail/local/myusername.ev-summary (adjust the filename)

Now you need to restart evolution and evolution-data-server, and it should rebuild the summary file.

share|improve this answer

Sounds like there might be a file permission problem. This could have occurred during the upgrade.

Open up a terminal (make sure Evolution is closed first). Type in: chown -R yourusername .evolution. Depending on the size of the directory, it might take a moment. Once you are returned back to the main prompt. Launch Evolution again to see if the same problem occurs.

If it does, please post exactly what it says.

share|improve this answer
    
Thanks Casey! Unfortunately, this is not the right solution :( However, I've got an error message, like this (it's in Hungarian, I try to translate) - 'Error during storage of „~/.evolution/mail/local/Inbox/myusername (mbox)”: The summary and directory are different even after synchronization.' - I did not understand, what does it mean, sorry :) –  zoly Oct 13 '10 at 13:25

Had the same problem, but then tried to delete the trashed mail by not selecting the mails and use the DEL key but just used the empty trash option in the file pull-down menu. This worked for me.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.