Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've a problem. I run ubuntu server on usb. And during installation I also used SD card as a swap space.

But the problem is that it's not being mounted at all.

If I check df I only see usb key - no sign of swap space, or another partition on it.

any ideas how to get to that partition?

p.s. even under /media/ I cannot find it. p.p.s. using mount command doesn't help either

share|improve this question

1 Answer 1

up vote 0 down vote accepted
swapon -s

is the right command to control your swap. Swap is not displayed when invoking the mount command. free is another option to find out about swap.

Sample output:

swapon -s
Filename                Type        Size    Used    Priority
/dev/sda8                               partition   2056280 11080   -1

free
             total       used       free     shared    buffers     cached
Mem:       1025756     995180      30576          0      76648     238908
-/+ buffers/cache:     679624     346132
Swap:      2056280      11080    2045200

If your sd-card is always present and usable as swap, put an entry into /etc/fstab, and use swapon -a.

share|improve this answer
    
adding entry to fstab and using swapon -a helped. thanks! –  Sandro Dzneladze Oct 14 '11 at 15:10
    
I removed my chatty comments, and included the summary into my answer. I invite you, to clear your comments too (too chatty). :) –  user unknown Oct 14 '11 at 17:21

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.