Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Every time I run Ubuntu on my Thinkpad the visual appearance of the system, desktop and applications does not look very crisp and the colors don't stand out. When I load windows 7, graphics are much nicer, crisp, and colors pop. Can I make Ubuntu have the same equivalent visual graphics that Windows 7 displays? Or because this is Linux the graphics are not as good for the intel hd 3000 chip on Ubuntu?

The best way I can describe the difference is on Windows 7 there is no "blur" on the desktop icons, menus, menu icons, and pictures,text, menus, really pop. On Ubuntu everything looks more dull and not "high def"

FWIW, I installed 11.10 beta 2.

share|improve this question
You sound like you haven't set the monitor to full resolution, or you need to adjust the contrast setting on your monitor ;) I didn't put this in an answer though because I didn't know if this was what you needed. – bntser Oct 13 '11 at 12:25
Maybe you can find help in this question's answers:… – Javier Rivera Oct 13 '11 at 12:26
If you're experiencing problems with washed out colors on external monitors over HDMI, try this: – namuol Jun 23 '15 at 22:00
up vote 2 down vote accepted

Both operating systems should be able to be as crisp as each other but without a visual comparison (could you take a couple of pictures?) it's hard to say exactly what the problem is.

However there are two things that spring to mind:

  • If you're not using the "native" resolution of a TFT/LCD screen that would cause everything to not be as crisp as it's supposed to be. I don't know what your native resolution is but the Windows display properties should give you a decent idea of what you're aiming for.

    With that information you should be able to use the Monitors tool in Ubuntu and match that resolution. If the same resolution isn't available, there's an issue that we need to deal with. Let me know and I'll write a follow-up on that.

  • You might just have font-hinting turned off. Sub-pixel hinting allows TFT displays to display things a lot more accurately by blurring parts of fonts into nearby pixels. This sounds like it would result in something less crisp, but it's actually very pleasant.

    In 11.04 and its predecessors you can get to these settings by right clicking the desktop and, clicking display properties, clicking the fonts tab and then checking Subpixel Smoothing under the rendering section.

    I have no idea how one does this in 11.10.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.