Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm using Ubuntu 11.10 with the default video driver because with the proprietary one the animations/window moving/video play is laggy and slow. With the default driver everything is fine except that after a while there is a strange graphic glitch and the card itself is burning. I don't know the exact temperature but if I touch the card while using Windows it's normal but when I use Ubuntu it's burning (without any stress in both cases). Here are some screenshots about the graphic problem:

share|improve this question
    
"default" is the one on the "Additional Drivers" application? –  Bruno Pereira Oct 12 '11 at 22:18
    
No. The one that comes with the Ubuntu installement. I didn't install anything else. –  Midori Oct 12 '11 at 22:20
    
install the recomended driver under "Additional Drivers" application, check if the temps go down. If stuff becomes laggy after that disable effects of compiz using the compiz manager. –  Bruno Pereira Oct 12 '11 at 22:21
    
Now the temperature is much better, but I couldn't disable the Window Decorations with the compiz manager because when I tried the whole launcher and the title bar of the windows are disappeared. The 2D version works prefectly tho. Is there any huge difference between that and the compiz one? Maybe I'll just stick with the 2D version. –  Midori Oct 12 '11 at 23:41
    
I use the 2d version by default because video and 3d games become choppy when using compiz effects, I really dont care about the effects at all. –  Bruno Pereira Oct 13 '11 at 0:03
add comment

3 Answers

up vote 6 down vote accepted

I have here a rather old Thinkpad with a Mobility Radeon HD 3400 series card, having similar problems:

  • The closed-source fglrx driver is almost unusable, due to flickering, glitches, etc with gnome-shell.

  • The open-source radeon driver is working very nice, but the card gets too hot. Checking using cat /proc/acpi/ibm/thermal shows that the card heats up to > 90°C.

My solution: - Use the open-source radeon-driver (accodring to the man-page your card is supported) and manually clock down the card: If it is not installed already, install it, the package is named 'xserver-xorg-video-radeon':

aptitude install xserver-xorg-video-radeon

Purge fglrx:

aptitude purge fgrlx

On the next start, X will automagically use the radeon driver. You can check this using 'lsmod | grep radon', you should see something like this:

root@XERXES3:~# lsmod | grep radeon
radeon               1015995  3 
ttm                    76805  1 radeon
drm_kms_helper         42558  1 radeon
drm                   236330  5 radeon,ttm,drm_kms_helper
i2c_algo_bit           13423  1 radeon

ensure that the fglrx driver is not loaded, 'lsmod | grep fglrx' should produce no output.

Check if your card is running at the highest speed too: 'cat /sys/kernel/debug/dri/0/radeon_pm_info' shows you the clock-speed of your card

root@XERXES3:~# cat /sys/kernel/debug/dri/0/radeon_pm_info 
default engine clock: 680000 kHz
current engine clock: 675000 kHz
default memory clock: 800000 kHz
current memory clock: 792000 kHz
voltage: 1200 mV
PCIE lanes: 16

Set the power-profile to something more reasonable:

echo "mid" > /sys/class/drm/card0/device/power_profile

Now check again the clock-speed of your card:

root@XERXES3:~# cat /sys/kernel/debug/dri/0/radeon_pm_info 
default engine clock: 680000 kHz
current engine clock: 297000 kHz
default memory clock: 800000 kHz
current memory clock: 405000 kHz
voltage: 900 mV
PCIE lanes: 16

It should show reduced clock-speeds and voltage.

That did the job for me. I'm now using gnome 3 for quite some time, things work very nice with Ubuntu. You might also be interested in this bug-report:

http://ati.cchtml.com/show_bug.cgi?id=99

It seems like ATI is having serious problems in providing a decent working linux-driver.

Also note, that this problem of "Radeon driver is clocking the card too hot" started to appear on my system with the introduction of KMS. It seems like the card is never switched to a reasonable power-profile, even if it is getting too hot. Before KMS, I was able to use in Xorg.conf the options "dynamic clocks on" (or similar) and the card adjusted its speed properly.

ATM I'm just setting the power-profile to "mid" each time after booting (a script could do the job).

Hope this helps, cheers

Note, I forgot to mention one thing: If you have a system with switchable graphics (in my case a thinkpad T400 with a ati card and a ibm gfx-chip), you need to disable the 'switchable graphics' in the bios and manually set in the bios which card to use (Discrete graphics in my case to use the ati-card). If not, it might happen that both cards are "powered-up" and are running at top-speed, producing heat. Here is a lot of informations about this:

http://en.gentoo-wiki.com/wiki/Lenovo_ThinkPad_T400#Getting_graphics_to_work

share|improve this answer
add comment

** Recommended actions when using an ATI 6900 series graphics card: **

1) Install the recommended drivers using the Additional Drivers application

2) Disable compiz effects using the Compiz Manager or select Ubuntu 2D as your interface by pressing the cog wheel when you login.

share|improve this answer
add comment

I answered about this problem another post. Check out this.

http://askubuntu.com/a/116045/14367

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.