Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Today I decided to install Ubuntu 11.10, and it did not recognize my resolution - 1440x900.

This has already happened in other versions of Ubuntu. However, in 11.10 I cannot get this resolved. Can anyone help me?

My PC:

  • Intel Corporation 82945G/GZ
    • Proview 19'' 1440x900
  • Ubuntu 11.10 (oneiric)
  • Kernel Linux - 3.0.0-12-generic

I tried the instructions in this blog post.

share|improve this question
add comment

2 Answers 2

Please generate an /home/"username"/xorg.conf.new that you can edit by adding a known good modeline in the applicable monitor section (if there are more than one).

To have the 1280x1024 resolution from the start on my HP vs17e monitor I included:

option "PreferredMode" "1280x1024"

(But I use Radeon driver on X600 discrete pci-e display adp, not the Intel.)

Save it under another name like /home/username/20-Proview.conf.

Press Ctrl+Alt+F1 for console 1, log in, and run:

sudo stop lightdm

Press Alt+F2 for console 2, log in, and run:

sudo cp 20-Proview.conf /usr/share/X11/xorg.conf.d/

Press Alt+F1 to return to console 1 and run:

sudo start lightdm

If there is no no error you get the greeter login.

If there is an error, return to console 2 and run:

less /var/log/Xorg.0.log

You can read this and see where the error (if any) occurred.

To undo a mistake just run:

sudo rm /usr/share/X11/xorg.conf.d/20-Proview.conf

(I apologise if I introduced typos--sometimes xorg has to be with capital X, as is the case for that log file.)

share|improve this answer
add comment

I have a similar problem with my monitor. Have you tried the usual randr commands?

xrandr --addmode VGA-1 1440x900
xrandr --output VGA-1 --mode 1440x900 --rate 60

Of course, change the value on rate to what refresh rate you want, and VGA-1 should be changed to what the name of your monitor is. If you need to find out the name just do

xrandr

and it will show you a list.

share|improve this answer
    
Well, I can even change the resolution. But when I restart from a mistake and goes back to what it was before. That is, I can not set the resolution. It must be because of LightDM. Why the other method, I ran a command that changed the resolution. –  Maiscedo Oct 12 '11 at 21:41
    
if the commands work to change the resolution just make an sh file with the commands in it, then go on the unity launcher and search for "startup applications" and add a new application and add as the command "sh /path/to/file.sh" –  merlin371 Oct 12 '11 at 21:49
    
It can be ... but I would like to change the resolution of LightDM too. What can not be done by "startup applications". Any tips? –  Maiscedo Oct 12 '11 at 21:59
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.