Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Has anyone had the same problem that I have with the full Nokia QT sdk offline installer that I have experienced with Ubuntu 11.1??

What happens is that when I run the installer it tells me that I need a C++ complier. Ok no issues there I just install one from software manager. The issue is that when it tries to install to /home/.../QtSdk the whole system hangs, HD active light comes on then nothing...

I reboot to fine my home folder has been corrupted and nautilus crashes.. I prefer the Nokia sdk because the repositories are a little behind the official nokia releases. Hope someone can help clear this issue for me....

share|improve this question

2 Answers 2

I spent quite some time because of this too (exactly the same problem). However, it works if you run the installer as root. I believe the issue is related to an incompatibility between Qt (the installer itself was built with Qt) and the new GTK. There are several error messages in the terminal if you run it normally, but I couldn't catch them due to the system instability after the installer is running.

share|improve this answer

"I prefer the Nokia sdk because the repositories are a little behind the official nokia releases."

You can still get an up-to-date copy of Qt through the package manager by adding the Forum Nokia Qt PPA. Type the following into a terminal to add this PPA:

sudo add-apt-repository ppa:forumnokia/fn-ppa ; sudo apt-get update

Now you can install an up to date version of Qt with:

sudo apt-get install libqt4-47-dev
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.