Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

In windows in keyboard switch settings there is an option that you can switch keyboard language with unique combination for each one.

For example, Ctrl + 1 - for english, Ctrl + 2 - for russian, Ctrl + 3 for ukrainian etc. It would be super handy, if there is an option to set this thing in Ubuntu.

Are there any options?

share|improve this question
    
Read Sneetsher's answer from this post. Then you will be able to set custom shortcut from keyboard settings. – VRR Jul 31 '15 at 14:01

You can do this using setxkbmap. From man setxkbmap:

The setxkbmap command maps the keyboard to use the layout determined by the options specified on the command line.

To do this, open Keyboard from settings and click on Custom Shortcuts. Click on the + sign and add fill up the 'Custom Shortcut' windows as shown below:

enter image description here

Press Apply. Click on 'Disabled' and press Ctrl + 2 to make this as a shortcut for enabling Russian.

Now repeat the steps, but add setxkbmap us as the command and Ctrl + 1 as the shortcut. This will enable Ctrl + 1 as the shortcut for English

share|improve this answer
1  
The problem is that it will not change the indicator in 14.04+. – Pilot6 Jul 31 '15 at 14:24
    
You are right, but is that a major problem? – Ron Jul 31 '15 at 14:26
    
still doesn't work – ﷲ اكبر Jul 31 '15 at 16:57
1  
Are you getting any errors? What's the output of setxkbmap -query after you've done Ctrl+2? – Ron Jul 31 '15 at 17:37

You can quickly switch between your installed keyboard layout by pressing Super + space bar.

For changing this keyboard shortcut go in :

System settings > Text Entry.

enter image description here (sorry screenshot not in English)

share|improve this answer
    
sorry, it doesn't work. I need those settings. Cause I'm using 4 languages. – ﷲ اكبر Jul 31 '15 at 13:38
    
Have you added your 4 languages in Input sources to use ? – hg8 Jul 31 '15 at 13:43
    
it doesn't work to set combination for a certain language – ﷲ اكبر Jul 31 '15 at 14:03
    
it should be - ctrl+1 - switches to english. Ctrl+2 - switches to russian. Idk if that's possible – ﷲ اكبر Jul 31 '15 at 14:05

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.