Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Like many Ubuntu users I'm using Compiz Desktop Effects with Gnome. However since Ubuntu 10.10 I've noticed that the zoom effect on my drop down menus i.e. The gnome menu bar have a flicking thin white border when they are opened. It appears very briefly and flickers each time a drop down menu is opened.

I can't remember this happening on Ubuntu 10.04 and it doesn't seem to be theme specific, as I tried it on Ambiance and Radiance and still see the flicking white border.

I'm using the nvidia-current proprietary driver enabled through Additional Drivers menu.

Thanks for any help on the matter!

share|improve this question
add comment

1 Answer

  • Make sure "Sync to vblank" is checked in "OpenGL Settings" in nvidia-settings
  • In CompizConfig Settings Manager, make sure your actual refresh rate is set in "General Options > Display Settings > Refresh Rate", "Sync to vblank" is checked, and "Detect Refresh Rate" is unchecked.
share|improve this answer
    
Thanks, I've carried out the changes you have stated, do I need to restart X? –  James Oct 12 '10 at 20:28
    
Actually, I just restarted my machine after the changes, but I still have the same problem. –  James Oct 12 '10 at 20:37
    
You need to save the changes in nvidia-settings to the xorg.conf file ("apply" is only temporary). –  mniess Oct 12 '10 at 23:01
    
Well I've tried the above and I still have the same problem. –  James Oct 13 '10 at 16:10
    
Try setting another effect in the "Animations" plugin and see if it has the same problem. –  mgunes Oct 14 '10 at 21:40
show 1 more comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.