Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This might be a dumb question, but I've googgled and searched for it and couldn't find any good answer.

I am using Maya 2011, which usually uses the ALT key as a shortcut by default for a lot of things (select objects, etc...). However, since Gnome uses ALT + click to drag windows, Maya does not let me use ALT for anything, and apparently the Windows key has taken now this role, so I can select objects through Windows key + click while ALT + click drags the whole window.

I know I can change the ALT key behaviour in Gnome in Windows Preferences -> Movement Key, but this does only changes ALT behaviour in Gnome, while Maya still uses Windows key for selection.

I am asking this because in KDE was a very simple thing to change, I remember I just changed something about modifier key, and it all went back to normal, without changing any configuration inside Maya, and I believe Gnome has to have a similar option that I cannot find.

Thanks!

share|improve this question
    
Ok, I'm such an idiot :) All I had to do was restart Maya after setting Preferences -> Windows -> Movement Key and set it to Super. Now you drag your windows using Super + click, and in Maya your ALT key behaves as expected. I was about to delete this question, but I will leave it in the system, just in case someone falls into the same error...... Cheers! –  Dan Oct 12 '11 at 9:16
    
Dan - well done - please add your comment as an answer. You will be able to accept it in a few hours time. –  fossfreedom Oct 12 '11 at 9:41
    
@fossfreedom If I do so I get this message "Users with less than 100 reputation can't answer their own question for 8 hours after asking. You may self-answer in 7 hours. Until then please use comments, or edit your question instead." I will add the answer in a few hours then :) –  Dan Oct 12 '11 at 9:49
add comment

2 Answers 2

up vote 1 down vote accepted

Ok, I'm such an idiot :)

All I had to do was restart Maya after setting Preferences -> Windows -> Movement Key and set it to Super. Now you drag your windows using Super + click, and in Maya your ALT key behaves as expected.

I was about to delete this question, but I will leave it in the system, just in case someone into the same error...... Cheers!

share|improve this answer
add comment

Go to

System->Preferences->Keyboard
Layouts
> Options...
   > Alt/Win key behavior
        > Left Alt is swapped with Left Win

Now you can run Maya.

http://rodmena.ourway.ir

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.