Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I was wondering if keyboard shortcuts (like Alt+F1, Alt+F2) support is removed from gnome shell 3.2?

If not then I'm missing something as I can't seem to use them.

share|improve this question
    
Are only the F1, F2, etc shortcut keys not working? Ie: If you do crtl+alt+tab nothing happens? –  Bruno Pereira Oct 11 '11 at 18:18
    
sorry for incomplete info. but Alt+Tab, Alt+Ctrl+Tab, Alt+F9, Alt+F7 are working –  wisemonkey Oct 11 '11 at 18:44
    
Can it be that you have a "fn" key in your keyboard? –  Bruno Pereira Oct 11 '11 at 18:45
    
I do have fn key on my keyboard but F1, F2 are accessible without fn key fn+(Function key) gives me extra functionality like sleep, battery stats etc. And Alt+F2 used to work until gnome (not Unity/gnome-shell) –  wisemonkey Oct 11 '11 at 18:58
add comment

3 Answers 3

up vote 3 down vote accepted

ok so by default Alt+F2 doesn't work in gnome shell [source: http://www.webupd8.org/2011/10/things-to-tweak-after-installing-ubuntu.html] Here is solution they have provided:

To fix it, open "System Settings" and under Keyboard > Shortcuts > System, click "Disabled" next to "Show the run command prompt" and press Alt + F2 - this should set Alt + F2 for running the command prompt.

share|improve this answer
    
Doesn't work, nothing happens when I click "Disabled" there. –  Reinis I. Jan 19 '12 at 14:32
    
Ugh. I felt pretty lame after looking right passed it for an hour... Thanks. –  XXninjatooXX Apr 11 '12 at 1:14
add comment

I had what I think was a similar issue although I'm not using gnome shell. It seems there may have been an issue in a recent update that was fixed in a more recent update. I was unable to use Alt+F2, but after updating just now, I am able to use them again. You might ensure you are updated since it sounds as if you are using 11.10 beta and see if one of the 100 odd updates fixes your issue. Sorry for the random shot in the dark, but I'm fully functional again.

share|improve this answer
    
nope didn't work just tried sudo apt-get update and sudo apt-get upgrade. Moreover on terminal mouse wheel scroll gives me previous commands rather than moving a page (previous behavior) –  wisemonkey Oct 11 '11 at 20:55
add comment

Seems there is another odd behavior in the Shortcut assignment. How can you Disable again an assigned combination? I mean, I don't want no more use the Alt+F2 combination, how can I disable that? The only way I found was to "Reassing" the Alt+F2 combination to another Shortcut, so the previous assignment is disabled. But this is a workaround, not a feature.

share|improve this answer
1  
Working perfectly on my machine, click on Alt + F2 NOT on Show the run command prompt and then change or disable by pressing Backspace. And you should have started new question as right now I'm the only one (not whole community) being notified of your question. Have fun :) –  wisemonkey Dec 18 '11 at 18:48
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.