Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just checked out the new ubuntu 11.10 Beta 2 64bit and I can't get my second screen to work.

It worked with kubuntu 11.04 (with binary drivers and with the drivers from nvidia website though not with the latest kernel, but I never checked why it was acting up before) and works with windows.

I installed the nVidia current driver from the 'Additional driver' tool and rebooted which didn't change anything. I then used the nvidia-settings tool and my second screen is marked as 'disabled'. When I enable it as twin-view, the resolution is set automatically but when I hit 'Apply', the following happens.

  • The image is mirrored on both screens
  • The image is scrambled
  • The image is only shown at the bottom lower half of the screen

After some time (I suspect the confirm settings dialog with a time-out) the screen becomes black and only the mouse pointer is shown. It can be moved, but sluggishly. I then have to kill the session from tty.

I installed the drivers from the nvidia website but they did the same thing. (And after 3 tries the system was so mixed up with nouveau and binary drivers that X wouldn't start and I had to restore my system from command line.)

share|improve this question
add comment

1 Answer 1

up vote 3 down vote accepted

This seems to be a problem with the nvidia binary driver and ubuntu 11.10.

To solve the problem open the 'terminal' application and run

sudo cp /etc/X11/xorg.conf /etc/X11/xorg.conf.back 
gksudo nvidia-settings

Now enter your password and set your desired settings. Now do NOT press 'Apply' but instead press 'Save to X configuration file' and press 'Save'.

Now logout and log back in. The second monitor should now be working.

If this does not help, press 'CTRL+ALT+F1' log in and enter the following

sudo rm /etc/X11/xorg.conf 
sudo cp /etc/X11/xorg.conf.back /etc/X11/xorg.conf

This will restore your settings.

Source: http://ubuntuforums.org/showpost.php?p=11359478&postcount=17

share|improve this answer
    
Per ubuntuforums.org/showpost.php?p=9038392&postcount=8 I added the "twinview" option to the only display entry in my xorg.conf -- which seemed to do the trick. The nvidia-settings did not offer the options I needed. –  Kimball Robinson Mar 23 '12 at 18:18
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.