Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I installed ubuntu 10.04, Apache, PHP, mysql, smb. Everything work fine in locally in my IP. When i trying to access my computer from LAN (other computer), it shows unable to connect. when i ping my IP from remote computer, its pinging OK. I can access internet, and all other systems (http, smb). But the problem is no one can't access my computer remotely in my LAN network.

My ip is 192.168.85.105 and i want access(Appaceh,SMB) from 192.168.85.10.

Is there any proxy firewall settings?

When i re-starting the system the same problem still exist.The system correctly ping from remote host.I have executed the above commands.Initially i run the command "sudo iptables -F" its okey in first time. now its not working, Please assist me ...

[OUTPUT OF iptables --list is given]**

    ashok@ashok-desktop:~$ sudo iptables --list
    [sudo] password for ashok: 
    Chain INPUT (policy DROP)
    target     prot opt source               destination         
    ACCEPT     tcp  --  resolver1.opendns.com  anywhere            tcp flags:!FIN,SYN,RST,ACK/SYN 
    ACCEPT     udp  --  resolver1.opendns.com  anywhere            
    ACCEPT     all  --  anywhere             anywhere            
    ACCEPT     icmp --  anywhere             anywhere            limit: avg 10/sec burst 5 
    DROP       all  --  anywhere             255.255.255.255     
    DROP       all  --  anywhere             192.168.85.255      
    DROP       all  --  base-address.mcast.net/8  anywhere            
    DROP       all  --  anywhere             base-address.mcast.net/8 
    DROP       all  --  255.255.255.255      anywhere            
    DROP       all  --  anywhere             0.0.0.0             
    DROP       all  --  anywhere             anywhere            state INVALID 
    LSI        all  -f  anywhere             anywhere            limit: avg 10/min burst 5 
    INBOUND    all  --  anywhere             anywhere            
    LOG_FILTER  all  --  anywhere             anywhere            
    LOG        all  --  anywhere             anywhere            LOG level info prefix `Unknown Input' 

    Chain FORWARD (policy DROP)
    target     prot opt source               destination         
    ACCEPT     icmp --  anywhere             anywhere            limit: avg 10/sec burst 5 
    LOG_FILTER  all  --  anywhere             anywhere            
    LOG        all  --  anywhere             anywhere            LOG level info prefix `Unknown Forward' 

    Chain OUTPUT (policy DROP)
    target     prot opt source               destination         
    ACCEPT     tcp  --  192.168.85.105       resolver1.opendns.com tcp dpt:domain 
    ACCEPT     udp  --  192.168.85.105       resolver1.opendns.com udp dpt:domain 
    ACCEPT     all  --  anywhere             anywhere            
    DROP       all  --  base-address.mcast.net/8  anywhere            
    DROP       all  --  anywhere             base-address.mcast.net/8 
    DROP       all  --  255.255.255.255      anywhere            
    DROP       all  --  anywhere             0.0.0.0             
    DROP       all  --  anywhere             anywhere            state INVALID 
    OUTBOUND   all  --  anywhere             anywhere            
    LOG_FILTER  all  --  anywhere             anywhere            
    LOG        all  --  anywhere             anywhere            LOG level info prefix `Unknown Output' 

    Chain INBOUND (1 references)
    target     prot opt source               destination         
    ACCEPT     tcp  --  anywhere             anywhere            state RELATED,ESTABLISHED 
    ACCEPT     udp  --  anywhere             anywhere            state RELATED,ESTABLISHED 
    LSI        all  --  anywhere             anywhere            

    Chain LOG_FILTER (5 references)
    target     prot opt source               destination         
    DROP       tcp  --  anywhere             anywhere            tcp dpt:hkp 
    DROP       udp  --  anywhere             anywhere            udp dpt:hkp 

    Chain LSI (2 references)
    target     prot opt source               destination         
    LOG_FILTER  all  --  anywhere             anywhere            
    LOG        tcp  --  anywhere             anywhere            tcp flags:FIN,SYN,RST,ACK/SYN limit: avg 1/sec burst 5 LOG level info prefix `Inbound ' 
    DROP       tcp  --  anywhere             anywhere            tcp flags:FIN,SYN,RST,ACK/SYN 
    LOG        tcp  --  anywhere             anywhere            tcp flags:FIN,SYN,RST,ACK/RST limit: avg 1/sec burst 5 LOG level info prefix `Inbound ' 
    DROP       tcp  --  anywhere             anywhere            tcp flags:FIN,SYN,RST,ACK/RST 
    LOG        icmp --  anywhere             anywhere            icmp echo-request limit: avg 1/sec burst 5 LOG level info prefix `Inbound ' 
    DROP       icmp --  anywhere             anywhere            icmp echo-request 
    LOG        all  --  anywhere             anywhere            limit: avg 5/sec burst 5 LOG level info prefix `Inbound ' 
    DROP       all  --  anywhere             anywhere            

    Chain LSO (0 references)
    target     prot opt source               destination         
    LOG_FILTER  all  --  anywhere             anywhere            
    LOG        all  --  anywhere             anywhere            limit: avg 5/sec burst 5 LOG level info prefix `Outbound ' 
    REJECT     all  --  anywhere             anywhere            reject-with icmp-port-unreachable 

    Chain OUTBOUND (1 references)
    target     prot opt source               destination         
    ACCEPT     icmp --  anywhere             anywhere            
    ACCEPT     tcp  --  anywhere             anywhere            state RELATED,ESTABLISHED 
    ACCEPT     udp  --  anywhere             anywhere            state RELATED,ESTABLISHED 
    ACCEPT     all  --  anywhere             anywhere   

Please give me the solution.

share|improve this question

1 Answer 1

up vote 2 down vote accepted

Did you change your ip-table settings ? Try to reset iptables

sudo iptables -F

or

sudo iptables-restore

[logout require] If it does not work then try to disable net-filter

sudo ufw --disable
share|improve this answer
    
Thanks your valuable time...We are searched long time.... –  Abdul Majeed Oct 11 '11 at 12:02
    
When i re-starting the system the same problem still exist.The system correctly ping from remote host.I have executed the above commands.Initially i run the command "sudo iptables -F" its okey in first time. now its not working. I tried all command you mentioned above, Please assist me ... –  Abdul Majeed Oct 12 '11 at 5:44
    
please paste the output of this command: sudo iptables --list –  shantanu Oct 12 '11 at 17:05
    
plz check the updated question with output of sudo iptables --list –  Abdul Majeed Oct 13 '11 at 5:13

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.