Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Everything worked fine in Ubuntu 10.04, flawless in fact, I admired the way the Operating System had handled such a unique touchpad so well. I have an HP Pavilion dv6.

The touchpad and left, middle, and right click buttons are all on the trackpad, and it the bottom end depresses to click accordingly for each kind of click.

In 10.04, everything worked fine, upon upgrading to Ubuntu 10.10 things became... odd. The scroll on the side would work, as would the left click. The right click wouldn't work however, but if you would lightly tap the exact right corner of the touchpad, the right click menu would come up, though it was inconsistent and difficult to make it do so.

I have applied a fix I found on the older Ubuntu Forums for a similar issue, and it restored the normal left and right click, but it isn't as fluid, and there isn't the vertical scroll feature, which I do rather like to have...

I would just like things to be as it was, if this is possible, please, please tell me how to do so.

Thank you.

share|improve this question

4 Answers 4

You may try reverting the change you did (or keeping it) and installing the gpointing-device-settings Install gpointing-device-settings package, which will provide more configuration options for your touchpad.

Once installed you find it under System -> Preferences -> Pointing Devices.

share|improve this answer

Create a file called /etc/modprobe.d/touchpad.conf

You can do this by typing sudo gedit /etc/modprobe.d/touchpad.conf in your terminal (Applications --> Accessories --> Terminal). It will ask for your password

when the file opens put in it options psmouse proto=imps Save the file and restart.

share|improve this answer
    
Thank you, I have done that, but it doesn't seem to have the vertical scrolling, or is there a way to enable that or something? –  Grayson Oct 12 '10 at 20:35

I have fixed my HP dv6 touchpad problem using the hack given in a comment on bug 549727.

Basically, copy and paste the following two line into the terminal and reboot.

gconftool --type bool --set /desktop/gnome/peripherals/touchpad/touchpad_enabled true
gconftool-2 --type string --set /apps/gnome_settings_daemon/keybindings/touchpad ""
share|improve this answer
    
cant thank you enough :) –  letronje Nov 23 '10 at 8:38

I am using the 'synaptics-dkms' module to enable multitouch on synaptics touchpads (find it here https://launchpad.net/~utouch-team/+archive/utouch ). I then configured a right click via two-finger tap, which works way better than the RBCornerbutton - rightclick!

I believe that synclient TapButton2=3 should be all you need to do to make it work.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.