Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm using Ubuntu 11.04 Natty on an HP laptop and I cannot figure out how to get Unity on the external monitor! I have my desk set up with my monitor in front of me, and my laptop working as a secondary about 45 degrees on the left. I've tried a few different suggestions, including trying (and not being able to find) nVidia-Settings. But as I am a relatively new Linux user, I am having a lot of difficulties understanding what I'm being instructed to do.

share|improve this question
add comment

2 Answers

up vote 1 down vote accepted

If your video card is xrand compilant (everything but NVIDIA, IRC), you can use this command:

xrandr --output VGA1 --primary

You will need to open a terminal: click on the dash and write Term. When the terminal, a blank screen with a cursor open, type the above command.

Note that the VGA1 parameter is just a good (I hope) guess. If it didn't work you should type in the terminal

xrand

And it will show you a list of the connected monitors and the resolutions that they support. In my laptop:

Screen 0: minimum 320 x 200, current 2726 x 768, maximum 8192 x 8192
**LVDS1** connected 1366x768+1360+0 (normal left inverted right x axis y axis) 270mm x 150mm
   1366x768       60.0*+
   1360x768       59.8     60.0  
   1024x768       60.0  
   800x600        60.3     56.2  
   640x480        59.9  
**VGA1** connected 1360x768+0+0 (normal left inverted right x axis y axis) 410mm x 230mm
   1360x768       60.0*+
   1024x768       75.1     70.1     60.0  
   832x624        74.6  
   800x600        72.2     75.0     60.3     56.2  
   640x480        72.8     75.0     66.7     60.0  
   720x400        70.1  
DP1 disconnected (normal left inverted right x axis y axis)

The names between the ** are the screen names. Take note of yours and change VGA1 in the above command for the name that apply to you.

You will need to issue this command just once, it will be remembered between reboots.

share|improve this answer
    
Thank you! The VGA1 worked, thank god, so i didnt have to go and try to find it. thank you alot!! –  Riley Sikora Oct 12 '11 at 5:31
    
This doesn't work if you have Intel graphic card, does anybody know how to make it work on Intel? –  Christian Vielma Mar 21 '12 at 14:59
    
It works for me in an Intel card, and it should as Intel driver works with xrandr. What exact model do you have?. –  Javier Rivera Mar 21 '12 at 15:36
add comment
  1. Go to monitors application, and disable the monitor you want to be secondary.
  2. The other monitor (external one) should become your primary monitor
  3. Re-enable your laptop screen.

You should be able to do this with the monitors Application, and with the nVidia control app as well.

share|improve this answer
    
This answer worked for me on ubuntu 12.04 –  Seth Jul 18 '12 at 15:52
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.