Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a linux HTPC (running XBMC) in my living room.

This morning I ssh'ed into the machine and did upgrade it to 10.10. When it finaly resarted it says something about running in low quality graphics and eventually returned to a command line login prompt. I ssh'ed in again and did a sudo reboot now. When it came back on this time the image is rapidly scrolling from the top to the bottom of the screen. I guess the installed driver doesn't quite work with the S-Video port on which the TV is connected.

previously it was working right with the nvidia proprietary drivers. How can I install thoses without using the GUI tool that comes with Ubuntu?

share|improve this question
up vote 14 down vote accepted

nvidia-xconfig will write a new default configuration file. You can then test it from there. If you need to edit the new file it will be located under /etc/X11

To install the drivers is sudo apt-get install nvidia-glx-xxx where xxx is the version whether it is 96, 173,185 depending on your card.

share|improve this answer
Tanks Casey, I suppose I'll have to install some package to get the drivers. Anyone know which package? – Mathieu Pagé Oct 12 '10 at 19:09
Just added that part. Sorry I left it out. You may also want to check out Nvtv TV Out to help you finetune the S-Video – Casey Keller Oct 12 '10 at 19:12
Thanks, it worked! – Mathieu Pagé Oct 14 '10 at 18:49

jockey is the tool used in Ubuntu to manage 3rd party drivers, particularly proprietary ones like the Nvidia drivers. In addition to the gui tool, it has a text based utility for manipulating drivers as well, jockey-text from the jockey-common package. To list what drivers jockey thinks are available for your hardware use jockey-text --list; e.g.:

jockey-text --list

returns (on my system with an ATI graphics chipset):

xorg:fglrx - ATI/AMD proprietary FGLRX graphics driver (Proprietary, Disabled, Not in use)

To then enable it, do sudo jockey-text -e DRIVER, thus in my case, to enable the fglrx driver, I'd do sudo jockey-text -e xorg:fglrx.

See jockey-text --help for more information (sadly, there doesn't appear to be a man page for it).

share|improve this answer
ubuntu-drivers replaces jockey tool for the new Ubuntu releases. – Jaime M. Jul 6 '14 at 16:13

I have nvidia driver installed and I solves this issue with

sudo ubuntu-drivers autoinstall
share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.