Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

If i with

dmesg | grep -i aspm

have this:

[    0.503709] ACPI FADT declares the system doesn't support PCIe ASPM, so disable it
[    0.673564] ACPI _OSC control for PCIe not granted, disabling ASPM

I've read that is a bug in the Linux kernel and I've also read that there is a workaround but I don't know if I have to apply this workaround or not.

So do I have to add pcie_aspm=force to grub2?

share|improve this question
    
see similar question: askubuntu.com/questions/38117/… –  fossfreedom Oct 11 '11 at 17:36
    
Have you solved this issue? –  pl1nk Jun 27 '12 at 8:12

2 Answers 2

Ok, i've add "pcie_aspm=force" and i've gained 20 minutes :)
So if someone have a Sony Vaio VPC-EH1S0E can easily add the parameter to the grub line in this way:

sudo nano -w /etc/default/grub

and where there is this line:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

change it into:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash pcie_aspm=force"

You can also check the power consumption with powertop:

sudo apt-get install powertop

and then:
sudo powertop
My battery consumption was decreased from 20.1W to 15.3W :)

share|improve this answer
    
This may work for some, and others have the same problem as me. See this comment: omgubuntu.co.uk/2011/11/… As you can see, at first they said I was nuts, a week later people asked me if there was any way to fix their batteries. –  RobinJ Dec 2 '11 at 12:57

this blog post explains well about kernel regression and aspm issue. May be it would be of some help.

share|improve this answer
    
i've read it...so it seem that i have to add the line to grub right? –  Paolo Oct 11 '11 at 7:47
    
If it says so.. –  sagarchalise Oct 11 '11 at 7:57

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.