Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've been using Oneric since the first beta version, and I'm using it on my Acer 5810TG laptop. Recently, though I don't know which day exactly, after performing routine updates from legit PPAs, Ubuntu started with Unity 2D only. Even if I pick "Ubuntu" or "User defined session" on the login screen, Unity-2D loads. I have built-in Intel graphics which always worked fine with Unity 3D, both on early versions of oneric and on natty.

Please suggest any possible reasons and/or ways to fix this.

share|improve this question

3 Answers 3

up vote 7 down vote accepted

You can try installing the latest version of the drivers for your graphics.

A ppa with the newest drivers can be found here.

Add it with

sudo apt-add-repository ppa:glasen/intel-driver
sudo apt-get update
sudo apt-get upgrade

install the xserver-xorg-video-intel using the command

sudo apt-get install xserver-xorg-video-intel
share|improve this answer
1  
this worked... beautiful, man, thanks a lot –  Zevaka Oct 10 '11 at 19:34
    
np, glad to help! –  Bruno Pereira Oct 10 '11 at 19:38
    
Can this driver be used with NVIDIA chipset as well? –  subeh.sharma Jan 23 '12 at 10:21
    
@subeh.sharma no, intel. –  Bruno Pereira Jan 23 '12 at 10:28

Aside from the PPA already mentioned by Bruno, there is another PPA by Fabio Pedretti with newer drivers than the Stefan Glasenhardt PPA. This PPA also contains newer ATI and nVidia drivers, so it's been a good all in one solution for me. I did have broken Intel graphics as he upgraded the PPA from Mesa 7.x to 8.x in January, but he fixed the issue quickly.

More info here: https://launchpad.net/~oibaf/+archive/graphics-drivers

Add it with:

sudo apt-add-repository ppa:oibaf/graphics-drivers 
sudo apt-get update
share|improve this answer

I had a similar problem with my intel i7 integrated graphics card:

$ /usr/lib/nux/unity_support_test -p
Error: GLX is not available on the system

It turned out some nvidia packages got installed somehow:

dpkg -l | grep nvidia

After removing every package with "nvidia" in it, it worked again.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.