Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have Dell Inspiron N4030 and I installed Ubuntu 10.10 desktop edition onto it.
But for some reason or another it will not boot into the GUI, I have installed and reinstalled Ubuntu and Ubuntu Netbook times over, but still with no luck.

The LiveCD is perfectly fine, but once I reboot its all in text-mode.
I tried doing 'startx' but it just made the screen go blank.
I don't know how, but at one point i was holding down the power button to turn it off after doing 'startx'.

I also tried nomodeset.
But then it just shutdown cause i was holding down the power button. Does anybody know how i could get the GUI to load on boot? Thanks for all your help!

If I installed higher version of Ubuntu say Ubuntu 11.04 is their going to be same problem.

Also I read it some where that problem is video driver

Please suggest solution

share|improve this question

1 Answer 1

up vote 2 down vote accepted

Your LiveCD works perfect because it uses vesa for graphics driver, you have as graphics an Intel HD that started to get support around 10.04 so there is a chance that something is going wrong during hardware detection.

More recent versions of Ubuntu fully support your graphics card (11.04 and the new 11.10 that is going to be released in a few days).

I recommend that you try out your laptop with 11.04, its stable, has full support and should support your graphics driver right out of the box.

Has options you can try to install a new graphics driver for your system, a ppa with the newest drivers can be found here.

Add it with sudo apt-add-repository ppa:glasen/intel-driver and after sudo apt-get update and a sudo apt-get upgrade install the xserver-xorg-video-intel using the command sudo apt-get install xserver-xorg-video-intel.

share|improve this answer
1  
+1 Will try today and let you know.Thanks for the update. –  Wazzzy Oct 10 '11 at 14:45
    
try the new drivers first, maybe its just that ;) gl –  Bruno Pereira Oct 10 '11 at 14:48
    
I have installed Ubuntu 11.04 and it perfectly worked for me...Thanks for your help –  Wazzzy Oct 11 '11 at 4:58

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.