Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

The gconf value /apps/gnome-screensaver/embedded_keyboard_enable in Oneiric no longer works obviously. Is there a way to show virtual keyboard in gnome-screensaver 3.x? Does similar dconf value exist? It makes unlocking the screen without the keyboard on tablets impossible.

share|improve this question

2 Answers 2

up vote 3 down vote accepted
+50

Gnome.org gives details of how to enable the embedded keyboard for a locked screen including the gsettings values

Any tablet-type screen keyboard must compy with the XEmbed specification.

Fortunately the standard onboard keyboard is XEmbed compliant - you need to pass the --xid parameter (type onboard --help for parameters you can pass to onboard)

Thus

gsettings set org.gnome.desktop.screensaver embedded-keyboard-enabled true
gsettings set org.gnome.desktop.screensaver embedded-keyboard-command "onboard --xid"

enter image description here

share|improve this answer

The gnome-screensaver was updated to use the new GSettings APIs instead of GConf. You can look through the list of options stored in GSettings by running gsettings list-recursively | less from a terminal, or by using the dconf-editor application.

The settings for gnome-screensaver have moved to the org.gnome.desktop.screensaver schema:

evan@caron:~$ gsettings list-recursively | grep org.gnome.desktop.screensaver
org.gnome.desktop.screensaver embedded-keyboard-command ''
org.gnome.desktop.screensaver embedded-keyboard-enabled false
org.gnome.desktop.screensaver idle-activation-enabled true
org.gnome.desktop.screensaver lock-delay uint32 0
org.gnome.desktop.screensaver lock-enabled true
org.gnome.desktop.screensaver logout-command ''
org.gnome.desktop.screensaver logout-delay uint32 7200
org.gnome.desktop.screensaver logout-enabled false
org.gnome.desktop.screensaver status-message-enabled true
org.gnome.desktop.screensaver user-switch-enabled true

So you can run gsettings set org.gnome.desktop.screensaver embedded-keyboard-enabled true to enable the onscreen keyboard. You may also need to change the embedded-keyboard-command key.

share|improve this answer
    
Thanks a lot :) Unfortunately, it didn't make keyboard work. But it was very useful information anyway and I'd rather split the bounty but I can't. –  int_ua Nov 15 '11 at 22:19

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.