Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I just downloaded the eclipse package from the eclipse website in zipped format. I unzipped it in my user directory and set 777 permissions, but double clicking the eclipse executable won't do anything. I tried running the executable file through terminal, but it shows the error:

bash: ./eclipse: No such file or directory

Then I installed eclipse through Ubuntu software center, which runs successfully. Just the downloaded version doesn't run.

I have installed OpenJDK in Ubuntu 10.10. Can anyone please tell what is wrong with my Eclipse?

share|improve this question
hit ls in the path your are, if you see the eclipse there, try chmod +x eclipse and ./eclipse, there also might be something wrong with the java version of your system try java --version and paste the output. – topless Oct 10 '11 at 10:47
I verified. The file is there and it is set as executable. java --version gave the following:- "Could not create the Java virtual machine." However, 'java -version' gave this:- "java version "1.6.0_20" OpenJDK Runtime Environment (IcedTea6 1.9) (6b20-1.9-0ubuntu1) OpenJDK 64-Bit Server VM (build 17.0-b16, mixed mode)". I'm running OpenJDK. – Sparky Oct 10 '11 at 11:08
I'm a bit worried about you mentioning "zipped format" - are you 100% sure you downloaded Linux version? Linux version is .tar.gz, and even has executable bit set on the 'eclipse' binary, so no chmod is necessary. – Sergey Oct 10 '11 at 11:48
@Sergey Yes, I downloaded the Linux version in a tarball (tar.gz) – Sparky Oct 10 '11 at 12:35
up vote 9 down vote accepted

My OS was actually 64 bit version. And the Eclipse package I downloaded was 32 bit. It seems stupid, but usually 32 bit softwares run without any problem in 64 bit operating systems. So I didn't pay much attention there.

I downloaded the 64 bit version of Eclipse and it works fine.

Thanks @Sergey for the time and patience.

share|improve this answer

The message from bash suggests that there is no such file - I suggest you to double-check that you're in the correct directory, that execute bit is indeed set etc.

Try invoking it like this:

cd ~/folder/where/you/unpacked-it
chmod +x ./eclipse

Actually, even changing permissions is not necessary - the binary already had executable bit set.

share|improve this answer
'Allow executing file as program' option is checked. I tried bash eclipse as you said. Then it showed "eclipse: eclipse: cannot execute binary file". Any idea? :( – Sparky Oct 10 '11 at 10:35
Yeah, Ubuntu's 'eclipse' command is a bash script while in the archive it is an ELF executable, so bash is not relevant here. – Sergey Oct 10 '11 at 11:41

I had the same problem about the Eclipse binary and started to follow the suggestions of this thread. I checked the OS and kernel versions, and tried to change the file permissions. After executing the chmod command I checked with ls -l and the output surprised me: nothing was changed.

After some more tries and a minute to think, I figure out the problem: The eclipse folder was in a directory outside the OS drive. It was on a NTFS drive, and I hadn't any special permission on it.

The easy solution was to take it back to the home/opt folder. But I'm still interested in a solution that enables the execution inside a NTFS partition.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.