Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

My Danish keyboard layout is not supported in Ubuntu, here's the layout

enter image description here

Available danish layouts on Ubuntu exclude the traditional mac function key. As a result I cant get to the 3rd and 4th levels of any key some are generally useful like the '@' symbol

share|improve this question
add comment

1 Answer 1

You need to set this up yourself. Go to [ System -> Preferences -> Keyboard ].

Under [ Layouts ], make sure that Danish/Denmark Macintosh is the selected one, and select Apple Macbook under [ Keyboard Model ]. Then click [ Options... ]. The list presented to you should contain an entry regarding what button(s) to use as 3rd level modifier keys.

Generally, many applications will expect the alt key to function as an alt key, so I would recommend not using that as a modifier in Ubuntu.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.