Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

What happens :

(1) video freezes after a few seconds of idling while audio remains intact.

(2) video resumes if I move the mouse.


What I tried :

(1) right click on a video -> "settings" -> uncheck "enable hardware acceleration"

(2) Chromium. (I usually use Firefox.)

(3) sudo pm-powersave false

(4) removed and reinstalled flash plug-in.

sudo apt-get autoremove flashplugin-installer

sudo apt-get autoremove flashplugin-nonfree

sudo apt-get install flashplugin-installer

(5) installed Flash-Aid and used it. (Both stable and beta options.)

No improvement so far.


UPDATE (More Info) :

sudo lshw -c display

*-display:0             
   description: VGA compatible controller
   product: Mobile GM965/GL960 Integrated Graphics Controller (primary)
   vendor: Intel Corporation
   physical id: 2
   bus info: pci@0000:00:02.0
   version: 03
   width: 64 bits
   clock: 33MHz
   capabilities: msi pm vga_controller bus_master cap_list rom
   configuration: driver=i915 latency=0
   resources: irq:44 memory:f0000000-f00fffff memory:d0000000-dfffffff ioport:1800(size=8)
*-display:1 UNCLAIMED
   description: Display controller
   product: Mobile GM965/GL960 Integrated Graphics Controller (secondary)
   vendor: Intel Corporation
   physical id: 2.1
   bus info: pci@0000:00:02.1
   version: 03
   width: 64 bits
   clock: 33MHz
   capabilities: pm bus_master cap_list
   configuration: latency=0
   resources: memory:f0100000-f01fffff
share|improve this question

2 Answers 2

up vote 1 down vote accepted

Lubuntu is by design a light-weight desktop environment with no compositor installed.

Flash I think requires some-sort of compositor to be present.

Suggestion would be to install the lightweight compositor such as xcompmgr and test this to see if Flash works correctly.

to install

sudo apt-get install xcompmgr

Then to test - open a terminal and run

nohup xcompmgr &

The nohup and & is important to run xcompmgr in the background including after the terminal has closed.

to run the xcompmgr from login

If xcompmgr works then you may wish to consider running this from login.

To do this first create the autostart folder if it doesnt already exist:

mkdir -p ~/.config/autostart

Then create a xcompmgr desktop file

lxshortcut -o ~/.config/autostart/xcompmgr.desktop

enter image description here

logout and login.

N.B. this picture shows what the xcompmgr.desktop file contains as well how to confirm xcompmgr is running.

enter image description here

share|improve this answer
    
I've tidied the solution with also a "how to" confirm that xcompmgr is running after login. –  fossfreedom Oct 12 '11 at 19:13
    
It worked perfectly!!! –  Robin002 Oct 13 '11 at 4:33

Install xcompmgr from a command line with:

sudo apt-get install xcompmgr

Open "Default Applications for LX Session" from the Preferences menu.

On the Composite Manager section, choose the 'Other' option where it says Command. Then enter the following in the box next to it:

xcompmgr

or, for a little bling:

xcompmgr -c -C -t-5 -l-5 -r4.2 -o.55

or, another bling-y one:

xcompmgr -cfF -t-9 -l-11 -r9 -o.95 -D6

Check the man page to work out all the options.

Then just set Autostart to true, Apply and Reload

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.