Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Every time I restore my computer from sleep or turn it on a window pops up asking for my wireless password. Once I enter it it connects successfully, but this happens every time. I'm using Ubuntu 11.10 with all updates installed. Shouldn't the password be remembered so you don't have to enter it every time I get on?

Anyone know why this is happening and how to fix it?

share|improve this question
    
Could pm-powersave be the cause of your problem? My answer to http://askubuntu.com/questions/65001/how-to-connect-wirelessly-in-a-cafe-with-1‌​1-04/65606#65606 might apply: –  waltinator Oct 13 '11 at 3:05
    
any progress? same issue here –  Balázs Mária Németh Oct 18 '11 at 15:43
    
I have this problem as well. When I first boot up my laptop computer, my computer logs in to my wireless network without any problem automatically. If I close the lid on my my laptop/suspend/hibernate computer, I keep getting prompted for my wireless network password, even though the prompt for my network actually shows that it has my password saved. My network connection properties also have the network settings saved for all users. It doesn't matter what desktop environment I use. Both Gnome 3.6 and Unity have the same problem. I'm using Ubuntu 13.04. –  user139162 Mar 10 '13 at 15:35

7 Answers 7

up vote 25 down vote accepted

I had the same problem. To fix this. Go to your network connections. From there click on wireless tab. Choose your connection and then click the edit button. Make sure your password is entered then click on the wireless security tab. Then check the box in the bottom left corner that says available to all users. This is what fixed the problem for me.

share|improve this answer
1  
This also worked for me. Thanks. –  Eric Wilson Oct 23 '11 at 0:49
1  
YES! This fixed the problem! Oh my goodness, you just made my day! :) This has been bugging me for SO long. –  jollypianoman Nov 13 '11 at 0:12
    
That would store the password outside of your user directory, right? –  queueoverflow Feb 15 '12 at 14:45
    
This is not an option for me. I want to have a guest account without password, but I do not want them to see all of my wireless passwords. The password for my university wifi can be used also elsewhere, so I have to keep it really secret. –  lumbric Jun 23 '12 at 7:20
    
any option tom make it not ask, just retry with stored password... btw knetwork-manager just connect, not asks, it is only gnome –  eicto Nov 27 '12 at 4:32

If you got the edit connections tab and look in wireless security. Is your password there. if not enter it and it should stay there.

share|improve this answer

Here is a slight variation of Hugo's answer. For me the problem was occuring with a particular network despite the "All users may connect to this network" checkbox being already checked. So what I did was to uncheck the box, save, check the box, then save again. I know this seems retarded, but it solved the problem for me.

share|improve this answer

Are you using an automatic login or du you need to type your password into lightdm when you start your computer? In a previous ubuntu version I had a similar issue and removing the automatic login did the trick. This is/was some strange security policy and I don't know if this solution will work for Ubuntu 11.10 / Gnome 3 but maybe this still works.

share|improve this answer

It's probably related to this bug

I have a variant of the bug, in which it created multiple prompts, but after a while managed to connect... turns out that in my case the issue was due to some duplicate connection configs of the same wifi

share|improve this answer

The real issue for me was weak signal, I attached an external antenna to fix that. This is a bug and no workaround worked for me. It seems to be related to the gnome keyring, but I could not figure out why it pops up while the box is filled in (i.e. password is saved).

share|improve this answer

I don't know how to fix that behavior but I do know an alternative method of security that's not as strong as the password but will still keep the many unwanted users off your network and not query you on every boot up. Set up MAC address blocking in your router and disable the password. Open up your browser and connect to the router. Frequently http://192.168.1.1, a router password will also be required. You'll then be able to look through the router's menu tree to find where it configures MAC address blocking. It's a good idea to set your router password to something other than the default. On my TRENDnet router the default password was "admin." You can find the correct IP and default password in the documentation that came with your router. If you can't find it you can download a new manual from the manufacturer.

share|improve this answer
15  
That is a terrible idea. It is the equivalent of fixing an issue with a front door that keeps locking you out by removing the lock and planting a tree in front of the door, hoping that nobody will notice the house... –  dovetalk Feb 29 '12 at 13:56
    
I don't have reputation on askubuntu.com enough to vote it down, but I would definitely do that if I could. –  Bart Apr 22 '12 at 14:36
    
I've made a suggestion that works with a caution that you're less protected than with a password. It isn't to Bart's liking so it's appropriate to recommend against my answer but to vote down a correct answer is hardly appropriate. –  fragos Apr 23 '12 at 1:25
6  
For everybody reading this: DON'T DO THAT! MAC addresses can be spoofed EASILY. Anyone can put its wireless card in promiscuous mode near your house, capture a few packets, take note of MAC addresses in the network and then replace its own MAC with a valid one to have full access to your network. WEP is not an option, MAC filtering is not an option, just WPA/WPA2 provide an acceptable level of security today. –  Avio Jul 13 '12 at 9:15
2  
It's not a correct answer. The questions were "Shouldn't the password be remembered so you don't have to enter it every time I get on? Anyone know why this is happening and how to fix it?". The problem isn't that it's less secure than a password, it's that it's not secure at all. –  Olathe Apr 8 '13 at 12:11

protected by Community Aug 16 '13 at 21:43

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.