Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

When I installed Ubuntu 11.10 Beta 2, during live-CD install, I tried out the new application switcher and it worked beautifully. After the installation is complete, the new application switcher is gone. In its place is a ugly grey Windows XP-ish thing.

I am not sure if this is a graphics driver issue, because I enabled nvidia proprietary driver. But other 3D related things looks fine. So how can I get the new application switcher back?

enter image description here

share|improve this question
Do you know if this is an error or is it just "supposed" to be this way? – Alvar Oct 8 '11 at 18:02
@hansioux Can you provide a screenshot? – Christopher Kyle Horton Oct 8 '11 at 18:23
screen cap added – hansioux Oct 9 '11 at 4:36
You are using Unity 2D. It looks pretty good here. I didn't install any video card drivers either. – Blue Pony Inc. Oct 9 '11 at 6:55
up vote 1 down vote accepted


This is very likely a driver issue. I had a somewhat similar problem when I installed the NVIDIA drivers from the NVIDIA website in 11.04. Replacing those with the drivers in the nvidia-current package fixed it.

In my case, I dropped to the console (CTRL + ALT + F1), stopped gdm and then re-ran the NVIDIA install script as root, but with the "--uninstall" parameter. After it finished removing that version of the driver, I installed nvidia-current and then rebooted. The eye candy is back (switcher, aero-ish snap, etc.). FYI: I use Gnome 2.3, but I don't think the problem was at that level.

So, in my case:

(from console)
$ sudo su -
# stop gdm
# sh /home/tim/Downloads/ --uninstall
# apt-get install nvidia-current
# reboot
share|improve this answer
awesome, thank you. i forgot about optimus... i'd try bumblebee, but i don't have too much time to play with it. – hansioux Oct 21 '11 at 17:44

It looks like if you are using Ubuntu 2D. When logging in, select "Ubuntu", instead of "Ubuntu 2D".

share|improve this answer
i am already logging onto Ubuntu, instead of Ubuntu 2D. I am thinking it might be some kind of driver issue, because instead of the nVidia card, phoronix says i am using Intel 2nd Generation Core Family IGP. But i have tried drivers provided by Ubuntu and by nVidia, and i still can't get it to work. – hansioux Oct 10 '11 at 17:34
Go into "System Settings" and under "System", click on "System Info" then it should give you the type of graphics card you are using under "Graphics". – Evan Oct 16 '11 at 6:21
You say "the Intel IGP rather than the nVidia card"? Is this an Optimus laptop? Installing the nvidia drivers will break any other 3D driver, so if you're using the Intel chip this will have broken Unity. – RAOF Oct 17 '11 at 6:23

Same thing here, updating from 11.04 to 11.10 in an Optimus laptop (Asus N53). Was working fine, but lost Unity effects (snap, switcher, etc) on the way :(

After some time, got solution here: Getting gnome-shell working on nvidia optimus notebook or within here:

So if: - Optimus laptop - No Unity effects (snapping windows, plain-ugly application/workspace switcher, no Unity handles, etc) - (even when upgrading from 11.04 where Unity3D was working fine)

then remove nvidia drivers to revert to intel onboard card with 3d support (see links above)

Thanks (again) AskUbuntu!!!

share|improve this answer

You can test your hardware for unity compliance, see:

share|improve this answer
bad link -- it's a parked domain – misha Jan 30 '13 at 2:31

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.