Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just upgraded to Oneiric and now the Unity Dash launcher is on my left screen. I really want it on my right screen. But how do I do that?

Why do I want the Dash on my right screen?

My left screen is a smaller older monitor that I use to read/watch documentation or keep my music player open. I work on my right screen, that is bigger and is a better monitor.

I have an Nvidia card and in the nvidia settings it is setup that the right monitor is my primary monitor, but Oneiric doesn't follow this setting anymore. I thought this was a bug, but is seems to be intended behavior... https://bugs.launchpad.net/ubuntu/+source/unity/+bug/742544

Some poster in this thread explains that he "patched it locally", but I have no idea how to do this. Does somebody know how to do this? Or maybe there is another solution?

share|improve this question
add comment

10 Answers

Unity has several issues with dual monitor setups. People are working on it, and it'll be an area of focus for the Precise Pangolin. I fixed this by switching connections on my VGA, but it really isn't a solution. But I guess we'll have to live with these small issues for a while.

share|improve this answer
1  
Thanks for your response.. But I can't see how switching my VGA would fix this... Since it is intended behaviour to always open the dash on the left monitor and not on the primary monitor... –  joris Oct 7 '11 at 14:12
add comment

In nvidia-settings in twinview mode you can set the primary monitor.

share|improve this answer
    
i mean primary monitor –  marin Oct 7 '11 at 14:49
1  
Yes you can set a default monitor, but this does not change the position of the Dash/launcher. It will remain on the left screen. Maybe my English is not good enough, but I hoped my question would be clear. You're answer would be correct in Natty. In Oneiric this does not work anymore. –  joris Oct 7 '11 at 14:53
    
In my case it works. Sorry I couldn't help. –  marin Oct 7 '11 at 17:07
    
Well thanks for trying to help, I guess you are just lucky it still works for you and I hope a future update does not break it ... –  joris Oct 8 '11 at 9:47
add comment

The simplest way is to just swap the leads then reconfigure the display settings so they are the right way round but the dash etc will be on the other screen. This assumes the monitors are the same making it easy to do this.

share|improve this answer
    
Thanks for your reply. But no my monitors are not the same. The one in the left is a much smaller screen. Moving the smaller monitor to the right is an option. I tried it, but couldn't really get used to it, don't know why. For the moment I switched to Xubuntu. –  joris Oct 15 '11 at 15:05
add comment

This ppa contains a patched version of unity, that will make sure that the dash is on your primary monitor.

https://launchpad.net/~vanvugt/+archive/unity

This is only a temporary fix, until a more permanent fix is ready.

share|improve this answer
add comment

It sounds a bit counter intuitive but I solved this problem by swapping the monitor order over in the NVIDIA control panel.

I have a laptop and a 27" LCD connected via HDMI. I keep my laptop on the left of my screen for various reasons. In order to get this to work I have the laptop screen set up to be to the right of the LCD. Therefore the Unity launcher will appear on the large LCD which is my main workspace. Obviously I have to remember to move windows to the right if I want them to be on the left hand screen.

share|improve this answer
add comment

You may be able to change the relative position of your monitors.

With the Nvidia tweaker dohickey, you can set this in the X server Display Configuration section. Typically the primary monitor is configured to be at 0,0 and the other one's position can be specified relative to the first. By combining this with playing with which monitor is plugged into which port on the tower, you might be able to get it working sensibly and the way you want it to.

share|improve this answer
add comment

I use a dual boot Windows / Ubuntu Media PC with a regular monitor and a TV attached. The idea has always been to watch the videos of recorded TV on the TV and do other stuff on the monitor which is to the right of that (the TV sits in the centre of the room for optimum viewing).

It seemed natural to me to set things up using the Nvidia tweaker to match that, with the TV on the left, so that the mouse would move as expected. when moved off the left of the monitor. Under Ubuntu 11.04 I could do that AND have the launcher at the left of the primary display - the monitor. However that doesn't happen with 11.10 and now I know why.

For me the ideal would be RIGHT instead of LEFT because then the launcher would be as far away as possible from the TV. The software isn't up to moving the launcher just yet. I've searched for alternatives and it is possible to set it at the BOTTOM of the screen using something called ADeskBar and another way via a Compiz plugin, but neither is very helpful. It would be good if this woul;d be something fixed in the next release.

If something can't be fixed exactly the way you want it, the next best thing is a workaround:

  1. Move the monitor to the left only using the tweaker. The launcher will appear again on the screen but the right hand side of that display will lead counter intuitively to the TV (which is physically on the other side); or
  2. Do the above AND swap the physical positions of the TV and monitor. The TV might be slightly less visible, but mouse will behave like you'd expect.

Let's hope that the next version of the launcher lets you put it where you want, like the task bar in windows.

Move the monitor to the left with the Nvidia tweaker. That will get the launcher to the

share|improve this answer
1  
You can hope that the next version of the launcher lets you put it where you want, like the task bar in windows, but realise that the current behaviour is intentional and that there is feature request for this that has a won't fix: bugs.launchpad.net/unity/+bug/668415 –  joris Jan 22 '12 at 14:23
add comment

I hope this solves the problem for you.

My problem was that I'm running 11.10 in a HP 13" laptop with a docking station. When in my desk, I close the laptop lid and the Launcher disappeared into the invisible fixed monitor.

My solution was this; System Settings (Configuración del Sistema) > Monitors (Monitores). Configure resolution for each monitor. In the same screen, deag the LEFT MONITOR (Primary) to the right of the other (secondary) monitor. That will effectively change their virtual placement.

share|improve this answer
add comment

This might help, I use two monitors.

First, here is my output running xrandr in terminal:


Screen 0: minimum 320 x 200, current 3200 x 1080, maximum 8192 x 8192
LVDS1 connected 1280x800+0+0 (normal left inverted right x axis y axis) 304mm x 190mm
   1280x800       60.0*+
   1024x768       60.0  
   800x600        60.3     56.2  
   640x480        59.9  
VGA1 disconnected (normal left inverted right x axis y axis)
HDMI1 connected 1920x1080+1280+0 (normal left inverted right x axis y axis) 700mm x 390mm
   1920x1080      60.0*+
   1280x720       60.0  
   1024x768       75.1     70.1     60.0  
   800x600        72.2     75.0     60.3     56.2  
   640x480        72.8     75.0     60.0  
   720x400        70.1  
DP1 disconnected (normal left inverted right x axis y axis)

I used compizconfig settings manager. In general options, go to "display settings" & add the two outputs in the Output list. Mine look like this:

1280x800+0+0
1920x1080+0+0

The first one is my laptop screen, where I work, LVDS1 and the second one is my hdmi to a vizio flatscreen where I'm watching films in vlc, HDMI1.

Now atop the Outputs list, select from Overlapping Output Handling "Prefer smaller output" or "Prefer larger output" depending on which one you want. So mine says:

Prefer smaller output

Also Detect Outputs is checked but I don't know if that helps or hurts, the only output originally listed was neither of my displays, something like 640x480+0+0.

As soon as I did this, programs open on my primary display just as I wanted rather than in the middle of the workspace, & the launcher is on the primary display & not the secondary(non-primary).

share|improve this answer
add comment

If this is still an issue with anyone a little google-ing around would have saved time, open terminal and run command xrandr --output HDMI-1 --primary (this is assuming there is only 1 HDMI connection but you can run the command xrandr and get a list of your monitors) if monitor name is different replace HDMI-1 with the proper device name of your chosen monitor.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.