Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I haven't very affinity with Networking/LAN, so I do not quite understand what's going on with my wireless driver, that's why I came here for help. My drive does not find any working wireless connection until I plug a network cable in. If I do this, it find working wireless connections and even if I plug the cable off, it stills on by wireless normally. So, I found this quite strange but this is it.

I typed 'ifconfig' in linux terminal and it returned 3 network interfaces: eth0, eth1 and lo. The eth1 is being displayed as Ethernet, but actually this is the wireless, I know this because if I turn wireless off(by laptop multimedia function Fn+F2) eth1 just disappears and i'm disconnected from internet.

So this is it. Is there some way to configure the wireless driver by any ifconfig command line? Or is there some other way to fix it?

Thanks!

P.S: Going to menu System > Administration > Additional drivers, it says I'm using Broadcom 802.11 Linux STA wireless driver.

share|improve this question

migrated from stackoverflow.com Oct 7 '11 at 11:18

This question came from our site for professional and enthusiast programmers.

add comment

1 Answer 1

up vote 0 down vote accepted

We might see ethernet and wireless as different types of network devices but they are both actually ethernet devices. On my motherboard I have two ethernet ports and an additional wireless adapter card. The ifconfig command lists all three as ethernet. See the line for wlan0.

wlan0 Link encap:Ethernet

I conclude that the wireless adapter/card is an ethernet device with an electronic circuit that receives and transmits using radio.

That, I think that answers the question in your title. Why you need to plug in an ethernet cable to get a wireless connection is a different question that could turn this post into a discussion. How many ethernet ports do you have? Is there a setting in the BIOS that links eth0 to eth1? Do you have another Operating System installed and is it affecting the operation of you network devices?

When you click the network icon is there a tick mark against both Enable Networking and Enable Wireless? When you put in the cable do you then click Enable Networking and do you click it again to remove the tick mark when you want to disconnect from the router? Doing this switches networking on and off and that includes wireless networking. This could be why it seems that you need to plug in an ethernet cable to get wireless networking.

Clicking Enable Networking to put a tick mark alongside it will activate Enable Wireless if it already has a tick mark against it. Put tick marks against both Enable Networking and Enable Wireless and leave them there and go to Edit Connections and set your wireless connection to connect automatically.

Regards.

share|improve this answer
    
I see. But as you said, this answer the question but not solve the problem. I think I should make a new topic for this problem, with the answers for your questions; this might help. Well, thank you for answering! –  Leonardo Raele Oct 8 '11 at 3:18
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.