Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I enabled Ubuntu One in 11.04 and marked my Documents folder for sync. Now, it's very slugish (which was mentioned here already), managed to upload only 160 MB in 5 days (it's a disaster IMO). Anyway, apart from being so slow, U1 fills my /tmp with the files to be synced (/tmp/tmpYemldG etc.), which makes my root partition to run out of space.

  1. The folder to sync is about 3.5 GB and all that is copied to /tmp. Why U1 doesn't sync "in place" doing compression on-the-fly? If I had, say 20 GB to sync, U1 would attempt to copy all of it to /tmp?

  2. Can I limit the amount of data copied to /tmp? While U1 is so terribly slow it doesn't really need more than it can handle. Even if the files to be synced have to be deflated to disk (which I doubt), this should be a small cache not the whole thing.

share|improve this question
add comment

3 Answers

That's not possible. It is necessary to make the switch in one go in order to provide any kind of conflict handling. Otherwise, you might suddenly end up with broken files if there was a power outage, etc. When you reboot, then the broken file would be synced across your personal cloud. That's really not what you want.

Another case is when you edit a file on different computers. You would need to know what the current version is. Downloading a new version should not affect the old version until it's completely downloaded. Only then should it be replaced with the new version, and this should be done in one go, probably by renaming the file.

share|improve this answer
    
You seem to answer question no 2. However, I disagree with your point. While it's necessary to operate on snapshots it definitely is not necessary to duplicate all the files and folders scheduled for sync. It would suffice to hash a snapshot and upload it while caching incrementally and rehashing in case of a change. It's a design flaw IMO to require a duplicate to operate. I don't need to duplicate my 3.5GB locally, I want them duplicated in the cloud. That's what a remote backup is about. U1 fails here. –  kaimadag Oct 11 '11 at 12:28
    
In order for something to be a duplicate, there has to be an exact copy. What should you compare with? But you're right, it should only attempt to download x files at the same time, not all of them. –  Jo-Erlend Schinstad Oct 12 '11 at 5:24
    
You also have to take into account that Ubuntu One is not a backup solution. It's a personal cloud. It's perfectly ok to have many computers. I can have a different version on my laptop, desktop and mobile. It's not like an external disk. –  Jo-Erlend Schinstad Oct 12 '11 at 5:29
    
This behavior is just wrong despite it being a backup solution or not. It should sync my files in the background to not disturb my work. I'm definitely disturbed when I can't send an email due to no free space in /tmp. –  kaimadag Oct 20 '11 at 12:57
    
sure. Synchronization is very difficult. Also, keep in mind that when you sync your documents folder and LibreOffice autosaves every minute or two, then the document also gets uploaded each time it autosaves. –  Jo-Erlend Schinstad Oct 20 '11 at 21:28
add comment

After four days I resorted to a final solution and disabled Ubuntu One sync daemon. This freed the /tmp and returned my system to a usable state again. This is the only way to solve this problem, I'm afraid.

U1, when running, is a hog on CPU and memory (and disk space in /tmp when creating a snapshot). Its hunger renders my 11.04 amd64 running on AMD Turion 64 X2 with 2 GB of ram unusable to a point in which I'm unable to send an email due to a lack of free space on root partition where my /tmp lives.

U1 effectively duplicates all files and folders scheduled for sync, which is unacceptable for me. I don't need a local copy of my files, I want them to be in the cloud. That's what a remote backup is about. Sorry U1, you failed.

share|improve this answer
add comment

This is actually a bug that existed in 10.10.

Bug #823647

I am seeing the exact same behavior in 10.10. When attempting to sync a ~3 GB file it fills up my 42GB / partition via huge files in /tmp. UbuntuOne sync is broken.

Dwain

share|improve this answer
    
Thanks, I might have expected it to be a bug. Anyway, it's unusable until it's fixed. –  kaimadag Oct 20 '11 at 12:55
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.