Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I recently installed 11.10b2, and when I try to install Adobe Flash, apt tells me that it conflicts with libc-bin. That doesn't sound quite right. Below is the output of sudo apt-get install flashplugin-installer before I aborted.

shawn@shawn-P35-DS3L:~$ sudo apt-get install flashplugin-installer
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following extra packages will be installed:
  flashplugin-downloader:i386 gcc-4.6-base:i386 libasound2 libasound2:i386
  libasound2-plugins:i386 libasyncns0:i386 libatk1.0-0 libatk1.0-0:i386
  libatk1.0-data libavahi-client3:i386 libavahi-common-data:i386
  libavahi-common3:i386 libc-bin:i386 libc-dev-bin libc6 libc6:i386 libc6-dev
  libcairo2:i386 libcomerr2:i386 libcups2 libcups2:i386 libcurl3:i386
  libdatrie1:i386 libdb5.1:i386 libdbus-1-3:i386 libexpat1:i386 libffi6:i386
  libflac8:i386 libfontconfig1:i386 libfreetype6:i386 libgail-common libgail18
  libgcc1:i386 libgcrypt11:i386 libgdk-pixbuf2.0-0 libgdk-pixbuf2.0-0:i386
  libglib2.0-0 libglib2.0-0:i386 libglib2.0-bin libgnutls26:i386
  libgpg-error0:i386 libgssapi-krb5-2:i386 libgtk2.0-0 libgtk2.0-0:i386
  libice6:i386 libidn11:i386 libjack-jackd2-0 libjack-jackd2-0:i386
  libjasper1:i386 libjpeg62:i386 libjson0:i386 libk5crypto3:i386
  libkeyutils1:i386 libkrb5-3:i386 libkrb5support0:i386 libldap-2.4-2:i386
  libnspr4:i386 libnspr4-0d:i386 libnss3:i386 libnss3-1d:i386 libogg0:i386
  libpango1.0-0 libpango1.0-0:i386 libpcre3:i386 libpixman-1-0:i386
  libpng12-0:i386 libpulse0 libpulse0:i386 librtmp0:i386 libsamplerate0:i386
  libsasl2-2:i386 libsasl2-modules:i386 libselinux1:i386 libsm6:i386
  libsndfile1:i386 libspeexdsp1:i386 libsqlite3-0 libsqlite3-0:i386
  libssl1.0.0 libssl1.0.0:i386 libstdc++6:i386 libtasn1-3:i386 libthai0:i386
  libtiff4:i386 libuuid1:i386 libvorbis0a:i386 libvorbisenc2:i386
  libwrap0:i386 libx11-6 libx11-6:i386 libxau6:i386 libxcb-render0:i386
  libxcb-shm0:i386 libxcb1:i386 libxcomposite1:i386 libxcursor1:i386
  libxdamage1:i386 libxdmcp6:i386 libxext6:i386 libxfixes3:i386 libxft2:i386
  libxi6:i386 libxinerama1:i386 libxrandr2:i386 libxrender1:i386 libxt6:i386
  nspluginviewer:i386 nspluginwrapper zlib1g:i386
Suggested packages:
  firefox:i386 x-ttcidfont-conf:i386 msttcorefonts:i386
  ttf-bitstream-vera:i386 ttf-dejavu:i386 ttf-xfree86-nonfree:i386 xfs:i386
  libasound2-python libasound2-python:i386 glibc-doc glibc-doc:i386
  locales:i386 cups-common:i386 rng-tools:i386 gnutls-bin:i386 krb5-doc:i386
  krb5-user:i386 librsvg2-common:i386 gvfs:i386 jackd2 jackd2:i386
  libjasper-runtime:i386 ttf-japanese-mincho ttf-thryomanes ttf-baekmuk
  ttf-arphic-gbsn00lp ttf-arphic-bsmi00lp ttf-arphic-gkai00mp
  ttf-arphic-bkai00mp ttf-japanese-gothic:i386 ttf-japanese-mincho:i386
  ttf-thryomanes:i386 ttf-baekmuk:i386 ttf-arphic-gbsn00lp:i386
  ttf-arphic-bsmi00lp:i386 ttf-arphic-gkai00mp:i386 ttf-arphic-bkai00mp:i386
  libsasl2-modules-otp:i386 libsasl2-modules-ldap:i386
  libsasl2-modules-sql:i386 libsasl2-modules-gssapi-mit:i386
  libsasl2-modules-gssapi-heimdal:i386
The following packages will be REMOVED:
  libc-bin
The following NEW packages will be installed:
  flashplugin-downloader:i386 flashplugin-installer gcc-4.6-base:i386
  libasound2:i386 libasound2-plugins:i386 libasyncns0:i386 libatk1.0-0:i386
  libavahi-client3:i386 libavahi-common-data:i386 libavahi-common3:i386
  libc-bin:i386 libc6:i386 libcairo2:i386 libcomerr2:i386 libcups2:i386
  libcurl3:i386 libdatrie1:i386 libdb5.1:i386 libdbus-1-3:i386 libexpat1:i386
  libffi6:i386 libflac8:i386 libfontconfig1:i386 libfreetype6:i386
  libgcc1:i386 libgcrypt11:i386 libgdk-pixbuf2.0-0:i386 libglib2.0-0:i386
  libgnutls26:i386 libgpg-error0:i386 libgssapi-krb5-2:i386 libgtk2.0-0:i386
  libice6:i386 libidn11:i386 libjack-jackd2-0:i386 libjasper1:i386
  libjpeg62:i386 libjson0:i386 libk5crypto3:i386 libkeyutils1:i386
  libkrb5-3:i386 libkrb5support0:i386 libldap-2.4-2:i386 libnspr4:i386
  libnspr4-0d:i386 libnss3:i386 libnss3-1d:i386 libogg0:i386
  libpango1.0-0:i386 libpcre3:i386 libpixman-1-0:i386 libpng12-0:i386
  libpulse0:i386 librtmp0:i386 libsamplerate0:i386 libsasl2-2:i386
  libsasl2-modules:i386 libselinux1:i386 libsm6:i386 libsndfile1:i386
  libspeexdsp1:i386 libsqlite3-0:i386 libssl1.0.0:i386 libstdc++6:i386
  libtasn1-3:i386 libthai0:i386 libtiff4:i386 libuuid1:i386 libvorbis0a:i386
  libvorbisenc2:i386 libwrap0:i386 libx11-6:i386 libxau6:i386
  libxcb-render0:i386 libxcb-shm0:i386 libxcb1:i386 libxcomposite1:i386
  libxcursor1:i386 libxdamage1:i386 libxdmcp6:i386 libxext6:i386
  libxfixes3:i386 libxft2:i386 libxi6:i386 libxinerama1:i386 libxrandr2:i386
  libxrender1:i386 libxt6:i386 nspluginviewer:i386 nspluginwrapper zlib1g:i386
The following packages will be upgraded:
  libasound2 libatk1.0-0 libatk1.0-data libc-dev-bin libc6 libc6-dev libcups2
  libgail-common libgail18 libgdk-pixbuf2.0-0 libglib2.0-0 libglib2.0-bin
  libgtk2.0-0 libjack-jackd2-0 libpango1.0-0 libpulse0 libsqlite3-0
  libssl1.0.0 libx11-6
WARNING: The following essential packages will be removed.
This should NOT be done unless you know exactly what you are doing!
  libc-bin
19 upgraded, 91 newly installed, 1 to remove and 432 not upgraded.
Need to get 36.0 MB of archives.
After this operation, 59.7 MB of additional disk space will be used.
You are about to do something potentially harmful.
To continue type in the phrase 'Yes, do as I say!'
 ?] 
share|improve this question
add comment

1 Answer

That looks partially right, in that it's pulling in all the i386 libraries required for flash. The removal of libc-bin is incorrect; you definitely don't want to remove it.

apt wants to update packages as a part of the install. Your system is not up-to-date, and this might be confusing apt slightly. If you run an update and then try this again, does it still want to remove libc-bin?

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.