Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

connecting with shared with other computers connection in NetworkManager. Other computer gets IP but NetworkManager disconnects the shared connection after half a second. This same setup worked perfectly fine in 11.04. Is there any fix, workaround or alternative way to share a connection with another computer over an Ethernet cable. (I can downgrade to 11.04 but I'd rather not ).

EDIT: found a workaround The workaround for now is to set IPv6 options to Ignore and then sudo killall dnsmasq. Reconnect and it should work.

share|improve this question
    
Can you post the fix as an answer? –  RolandiXor Feb 5 '12 at 20:34
    
add comment

closed as off-topic by Braiam, guntbert, Eric Carvalho, blade19899, psusi Dec 3 '13 at 16:53

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Bug reports and problems with the development version of Ubuntu should be reported on Launchpad so that developers can see, track and fix these issues." – Braiam, guntbert, Eric Carvalho, blade19899, psusi
If this question can be reworded to fit the rules in the help center, please edit the question.

5 Answers

It is not fixed yet. I have had this issue just now and the workarround mentioned by the OP did the trick.

The workaround for now is to set IPv6 options to Ignore and then sudo killall dnsmasq. Reconnect and it should work.

share|improve this answer
add comment

This article seems to address the issue. Appears that dnsmasq should be removed. https://help.ubuntu.com/community/Internet/ConnectionSharing

share|improve this answer
add comment

Yes, that is a bug and it's supposed to have been fixed. I haven't had the time to test it myself yet, but you might want to. This site is for questions and answers. Bugs are handled on Launchpad.net. Here's a direct link to the bug you're after: https://bugs.launchpad.net/ubuntu/+source/network-manager/+bug/865001. Please describe details about your situation and hopefully it'll get fixed before release.

That bug thread has a workaround that is supposed to work, but as I said, I haven't had the time to test it yet.

share|improve this answer
    
thank you very much –  approbatory Oct 6 '11 at 4:33
add comment

I had the same problem but discovered that I had a regular network patch cable connecting my Netbook to my HD Home Run. I replaced it with a crossover cable and the intermittent connect/disconnect messages went away.

share|improve this answer
add comment

I had to sudo killall dnsmasq first so I could click the config box then set ipv6 to ignore then sudo killall dnsmasq again...taken me about 4 hours to get connection sharing to work (just dumped Windows).

share|improve this answer
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.