Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When I open a letter size PDF and then zoom to 100%, the page physically displayed on my monitor is smaller than a real letter size sheet of paper.

How can I make "100%" on the computer screen correspond with "100%" in real life?

Details

This message suggests that I should be investigating the system-wide DPI settings for my monitor. xdpyinfo reports:

dimensions:    1024x768 pixels (271x203 millimeters)
resolution:    96x96 dots per inch

My monitor has a native display resolution of 1024x768 pixels and a diagonal display size of 12.07 inches. PX CALC returns the following information:

DPI: 106.05
Dot Pitch: 0.2395mm
Size: 9.66" × 7.24" (24.53cm × 18.39cm)

What I've tried so far

Running xrandr --dpi 106.05 successfully caused my PDF to appear actual size at 100%, but this effect was lost after rebooting.

To make the setting persistent I tried creating the following /etc/X11/xorg.conf:

Section "Monitor"
    Identifier   "ThinkPad X60 LCD"
    DisplaySize  245 183
EndSection

Section "Screen"
    Identifier "Screen0"
    Monitor    "ThinkPad X60 LCD"
EndSection

After re-logging in, /var/log/Xorg.0.log contained

[  1167.824] (**) intel(0): Display dimensions: (245, 183) mm
[  1167.824] (**) intel(0): DPI set to (106, 106)

but xdpyinfo still reported

dimensions:    1024x768 pixels (271x203 millimeters)
resolution:    96x96 dots per inch

and "100%" still appeared too small.

share|improve this question
    
Couldn't you just run xrandr --dpi 106.05 as a script at startup? –  desgua Feb 10 '12 at 14:12
    
On my computer, that xrandr --dpi 125 call does not change anything in Okular or Xournal … –  queueoverflow Jul 12 '12 at 9:48

4 Answers 4

up vote 6 down vote accepted
+25

xorg.conf doesn't even exist on new installs nowadays because of xrandr. Most drivers work fine with just xrandr and no xorg.conf (I think Nvidia is the exception). What you need is to have xrandr run at startup all the time. I documented on the Ubuntu Wiki how to make xrandr commands run as soon as the GUI starts. Just use the same xrandr command you already figured out.

For Unity users reading along, equivalent directions for lightdm are here: http://askubuntu.com/a/69501/1158

share|improve this answer
    
xorg.conf now exists in the form of /usr/share/X11/xorg.conf.d –  Richard Ayotte Feb 16 '12 at 15:22

There's a good answer on this blog about Display Size, DPI, and Text Size… an interesting DIY. He even includes a script to do the configuration automatically on startup. You will need to tweak it for your configuration though.

share|improve this answer

You are obviously on the right track, since you found that changing the DPI settings worked when you ran the xrandr command.

It used to be easy to change the DPI setting in Gnome itself, but apparently, Gnome 3 made this difficult.

You can check out this answered question on AskUbuntu for info about how to go about it in Gnome 3:

How do I change the font DPI settings?

share|improve this answer

That's actually a very complicated question.

I can't tell you how to solve your problem, but I can tell you why it occurs. Monitors have different pixel densities. A 1x1cm square on one monitor can contain a different amount of pixels that the same square on a different monitor. See http://en.wikipedia.org/wiki/Pixel_density for more information on that.

Because of this, 100% zoom will give you differently sized documents on different monitors.

Given this context, this question is probably better phrased as "how can I change what 100% means in Evince?" I don't know the answer to that. Sorry. I do hope my answer helps somewhat, though.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.