Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I had to kill a VMWare process and afterwards, my monitor's configuration is buggy.

I have 2 monitors in a side-by-side configuration. My right-hand monitor is the secondary monitor.

Upon its right-hand side there are about 50 pixels showing from the left side of the lefthand monitor (ie, as if it was wrapped around). Further, my mouse clicks are registering as about 50 pixels sideways from where they should be.

It's as if those 50 pixels between monitors got gobbled.

What have I done?

  • I've reset the screen configuration in multiple ways, using xrandr, multiple monitors app, etc. This persists in different side-by-side configurations, and also persists with another user.

  • It does not occur with XFCE.

  • Resetting the Window manager with the Compiz reset WM app does not fix this.

I've concluded the burn-to-the-ground approach is likely the best, and would like to do a 100% reset of my graphics settings. It's an Intel integrated chipset.

  • Removing ~/.config/monitors.xml did not work. Also, interestingly, the mouse can mouse-over the 50 errant pixels on the rhs of the right-hand monitor. I hypothesize that it's a compositing problem occurring at the layer where the background, selection, and clicks are caught. Also, inverting the right-hand monitor removes the issue, but renders the screen unusable.

Even more datapoints:

  • This happens in KDE as well

  • Sometimes logging into Gnome and running xrandr --output DVI1 --auto resets it, but the issue immediately reappears when I press alt-tab.

  • With Compiz Application Switch turned on, the workspace is 'pushed back' a bit, and the slice on the RHS follows it as well. I'm wondering if it's a flaw in the compiz workspace compositing configuration.


I suspect the error was in the compositing configuration.

I installed 11.10.

share|improve this question
    
Does this affect the dm login screen as well? We can then start to eliminate it being individual user settings. –  Danny Staple Nov 4 '11 at 23:07
    
@DannyStaple: It did not. It affected KDE and Gnome on multiple users. I installed 11.10, so I 'eliminated' the bug. –  Paul Nathan Nov 5 '11 at 3:17
    
I think a little info about your video card should help to answer this. –  H_7 Nov 12 '11 at 13:56

5 Answers 5

lkjoel has written this blog post:

Press CTRL+ALT+F3

Log in

Type:

sudo rm -f /etc/X11/xorg.conf
sudo rm -f xorg.conf*
sudo service lightdm stop
sudo service gdm stop
sudo service kdm stop
sudo service lxdm stop
sudo service xdm stop
sudo service wdm stop
sudo Xorg -configure
[ -f xorg.conf* ] && sudo mv xorg.conf* /etc/X11/xorg.conf
sudo dpkg-reconfigure $(dpkg -l | awk '{print $2}' | grep "^xserver" | tr '\n' ' ')
sudo update-initramfs -u

Reboot

may be it help

share|improve this answer
    
You just copied my post! lkubuntu.wordpress.com/2011/08/30/… –  MiJyn Nov 12 '11 at 1:12
    
@lkjoel: i copied to help this guy. if u want me 2 declare in answer then i will . thanks 2 u –  Gaurav_Java Nov 12 '11 at 4:09
    
Gaurav, If you cite someone's content (which is fine), you need to mention the source in your answer and clearly mark it as a citation. I've edited your post for now. –  Stefano Palazzo Nov 26 '11 at 0:58

I feel sorry to say that you may have to re-install OS. You may think that it will take a lot of time to mature the system again but that is only way to 100% reset your graphics settings. You will try fixes only to realize that you are exacerbating the situation and waste more time.

Also take my advice and don't use restricted (fglrx) or vendor drivers at least for now, that way you will not have the problems you faced now.

share|improve this answer

Update or reinstall your graphics card driver, and if that doesn't work, go to your monitor settings and change it to defaults.

share|improve this answer
    
This is a not a proper answer. –  topless Oct 19 '11 at 8:44

According to this site, http://linuxfud.wordpress.com/2007/02/14/how-to-reset-ubuntugnome-settings-to-defaults-without-re-installing/, if you issue the command in tty1 (Ctrl+Alt+F1)

rm -rf .gnome .gnome2 .gconf .gconfd .metacity

Then it states to get back to the GUI (Ctrl+Alt+F7) and it's like "logging into Gnome" for the first time after install.

For the record, I'm weary of any command involving rm -rf so if you want to try it, do so at our own risk. According to the site though, this only resets gnome specific settings, not video card or display or xserver.

share|improve this answer
    
this persists between multiple users. –  Paul Nathan Oct 13 '11 at 1:18
    
According to the site, this will 'reset' gnome for all users. –  P05TMAN Oct 13 '11 at 17:07
3  
Uh, no. It explicitly calls it out as per-user. Also, the architecture of the system is such that settings in your ~ directory are per-user. –  Paul Nathan Oct 13 '11 at 18:07

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.